This question already has an answer here:

Recently I upgraded my Ubuntu machine from 14.04 to 16.04. At first my wifi was working fine, but after two days the system is not showing any wifi settings/connection. Can anyone please help me out this?

enter image description here


No luck here, I tried to run the script but it gives an error. I am new to Ubuntu Ι don't know what this script does. Any help?

bakkireddy@bakkireddy-Z5WAH:~$ sudo systemctl restart network-manager.service 
[sudo] password for bakkireddy:
bakkireddy@bakkireddy-Z5WAH:~$ sudo systemctl restart network-manager.service #/etc/systemd/system/wifi-resume.service
bakkireddy@bakkireddy-Z5WAH:~$ #sudo systemctl enable wifi-resume.service
bakkireddy@bakkireddy-Z5WAH:~$ [Unit]
[Unit]: command not found
bakkireddy@bakkireddy-Z5WAH:~$ Description=Restart networkmanager at resume
networkmanager: command not found
bakkireddy@bakkireddy-Z5WAH:~$ After=suspend.target
bakkireddy@bakkireddy-Z5WAH:~$ After=hibernate.target
bakkireddy@bakkireddy-Z5WAH:~$ After=hybrid-sleep.target
bakkireddy@bakkireddy-Z5WAH:~$ 
bakkireddy@bakkireddy-Z5WAH:~$ [Service]
[Service]: command not found
bakkireddy@bakkireddy-Z5WAH:~$ Type=oneshot
bakkireddy@bakkireddy-Z5WAH:~$ ExecStart=/bin/systemctl restart network-manager.service
restart: Unknown job: network-manager.service
bakkireddy@bakkireddy-Z5WAH:~$
bakkireddy@bakkireddy-Z5WAH:~$ [Install]
[Install]: command not found
bakkireddy@bakkireddy-Z5WAH:~$ WantedBy=suspend.target
bakkireddy@bakkireddy-Z5WAH:~$ WantedBy=hibernate.target
bakkireddy@bakkireddy-Z5WAH:~$ WantedBy=hybrid-sleep.target
bakkireddy@bakkireddy-Z5WAH:~$ sudo systemctl enable wifi-resume.service
Failed to execute operation: No such file or directory

marked as duplicate by user117103, Zanna, Kevin Bowen, Anwar, Eric Carvalho Sep 18 '16 at 1:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

protected by Community Sep 18 '16 at 6:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.