Using 14.04, i have intermittent issues with audio (works then stops), tried many tips (and actually reverted from 16.04 to a fresh 14.04) but it's still there...


When applying the troubleshooting procedure, i noticed that the driver is referenced with different names in different places using dash or underscore : snd-hda-intel in sound modules, snd_hda_intel in hardware devices.

Why these different names ? could this have an impact ?

Thanks for your help

Sound module

find /lib/modules/`uname -r` | grep snd | grep hda | grep intel


Physical audio hardware

lspci -v | grep -A5 -i "audio"

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
    Subsystem: Intel Corporation Device 204f
    Flags: bus master, fast devsel, latency 0, IRQ 29
    Memory at f7d30000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

Soundplay cards and devices

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I had similar problems with intermittent audio where the device was listed in aplay -l but there was still no sound. Output from dmesg showed the real issue:

snd_hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x01270700
snd_hda_intel: No response from codec, disabling MSI: last cmd=0x01270700
snd_hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x01270700

To fix it by adding this line in /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel probe_mask=1

Source: https://help.ubuntu.com/community/HdaIntelSoundHowto#Playing_with_probe_mask

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.