0

Pre-post: My machine is an HP laptop, and I have heard that HP's EFI implementations are horribly bugged. I'm not sure if this is the cause of the problem. Trying to modify the boot order with efibootmgr does nothing. Manually moving the .efi files around caused my computer to display a large screen of white text, and then revert back to the Boot Manager screen.


This is a "problem" that has really been bugging me.

Back in December, I made the switch to Linux because my Windows 10 installation conked out on me. (Hint: don't format the NTFS partition.)

So, now I have a incredibly dead Windows 10 install (the only thing residing is the boot manager and the recovery partitions), a Xubuntu 15.10 install, a Lubuntu 14.04 install, and an Ubuntu GNOME 16.04 install. (This one is my main installation.)

Whenever I need to boot into my Linux distro, I need to press F9 to get to my firmware's Boot Selection screen. From there I select the option ubuntu (insert disk serial number here), which brings me to the GRUB menu.

However, I find this key press to be quite annoying. If I don't press F9, my system boots into your standard Windows 10 recovery screen.

What I want is for my system to automatically boot into GRUB instead of that recovery screen.

I have already tried efibootmgr and mving the .efi files, to no effect. My computer's firmware setup screen doesn't have an option for "Custom" in the boot order options. It merely presents this:

**--- Boot Options (F5=up, F6=down) ---**  
> External USB Drive  
> External CD-ROM Drive  
> Internal Notebook Drive  
> Network Adapter  

I have no option for the EFI shell, and I think I don't have it installed.

So, is there any way to make GRUB the default loader?

  • What is the exact model of your hardware then? And the bios version? – FredFoo Sep 17 '16 at 7:12
  • @FredFoo Laptop is an HP Notebook 15-f004wm. I can't say the BIOS version, but the setup utility is Insyde H20. – InitializeSahib Sep 17 '16 at 7:17
  • What type is your efi partition? EF00 or EF02? – FredFoo Sep 17 '16 at 7:59
  • @FredFoo I believe EF00 – InitializeSahib Sep 17 '16 at 23:49
  • Perhaps it helps to have a look at this superuser.com/questions/764799/… – FredFoo Sep 19 '16 at 3:22
0

This is the reason. Basically, "Some motherboards override by default any settings set with efibootmgr by Windows if it detects it. This is confirmed in a Packard Bell laptop."

  • Looks like I'll have to stick with pressing F9... Thanks for the info! – InitializeSahib Nov 30 '16 at 0:09
0

Usually for uefi you would do that through your bios settings. I dont know your model but so far all notebooks I dealt with had a uefi boot setup that would - analog to the boot drive selection - list out all bootloaders that are found on your boot drives efi partition. Then you would select which one should be tried first, second and so on.

Have a look through your bios options.

  • I have. No option to be found. – InitializeSahib Sep 17 '16 at 7:04
  • Okay, maybe time to swing Mjölnir :)) Boot into your linux, backup your efi partition, wipe it clean, reinstall grub, see what happens. You can check what is on the efi partition before rebooting, to be safe. I did this a few times when things got too cluttered. – FredFoo Sep 17 '16 at 7:11
  • This just went from 0 to 100 REAL quick. Are there any other options, besides wiping the EFI partition? I am running an HP Notebook 15-f004wm. – InitializeSahib Sep 17 '16 at 7:15
  • Well, it is the bios job to allow you to select from what is presented. If it does not do that job, then your only option is to select what will be presented. In the end it is the bios that boots your system and theirfor it will always be the bios that selects. Cant do much about it. Unless HP provides some fancy tool for it, but there I have to say sorry - dont know nothing about that ;-/ – FredFoo Sep 17 '16 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.