0

I am having problems with boot time with 16.04. How can I solve it? Can't understand the logs...

Here are the outputs of various commands:

$ systemd-analyze critical-chain
graphical.target @1min 30.597s
└─lightdm.service @1min 30.395s +201ms
  └─systemd-user-sessions.service @1min 30.195s +57ms
    └─basic.target @1min 30.177s
      └─sockets.target @1min 30.177s
        └─snapd.socket @1min 30.177s +223us
          └─sysinit.target @1min 30.173s
            └─systemd-backlight@leds:dell::kbd_backlight.service @1.175s +14ms
              └─system-systemd\x2dbacklight.slice @587ms
                └─system.slice @87ms
                  └─-.slice @85ms
$ systemd-analyze
Startup finished in 2.146s (firmware) + 6.268s (loader) + 7.608s (kernel) **+ 3min 423ms (userspace)** = 3min 16.447s
$ systemd-analyze blame 
660ms dev-sda4.device
223ms plymouth-quit-wait.service
205ms accounts-daemon.service
201ms lightdm.service
190ms ModemManager.service
182ms apparmor.service
175ms gpu-manager.service
160ms systemd-logind.service
157ms systemd-rfkill.service
125ms grub-common.service
121ms ondemand.service
119ms apport.service
118ms irqbalance.service
115ms console-setup.service
102ms NetworkManager.service
 98ms upower.service
 92ms speech-dispatcher.service
 85ms systemd-localed.service
 78ms alsa-restore.service
 75ms keyboard-setup.service
 65ms networking.service
 62ms systemd-udev-trigger.service
 57ms systemd-user-sessions.service
 57ms systemd-udevd.service
 57ms pppd-dns.service
 51ms systemd-update-utmp.service
 48ms systemd-hostnamed.service
 47ms bluetooth.service
 47ms thermald.service
 44ms udisks2.service
 42ms rsyslog.service
 38ms systemd-timesyncd.service
 38ms avahi-daemon.service
 36ms systemd-fsck@dev-disk-by\x2duuid-BE0A\x2dCB90.service
 35ms systemd-journald.service
 34ms snapd.firstboot.service
 34ms wpa_supplicant.service
 32ms resolvconf.service
 25ms plymouth-start.service
 24ms user@1000.service
 23ms systemd-modules-load.service
 20ms polkitd.service
 19ms systemd-journal-flush.service
 15ms colord.service
 14ms dns-clean.service
 14ms systemd-backlight@leds:dell::kbd_backlight.service
 14ms boot-efi.mount
 13ms systemd-tmpfiles-setup.service
$ blkid
/dev/sda1: LABEL="GRUB" UUID="BE0A-CB90" TYPE="vfat" PARTUUID="d8fb4ac0-c0b7-427d-8507-0cf43b27043c"
/dev/sda2: UUID="e3a1dc8a-52d3-4cb4-ab5a-4ecf745a10f5" TYPE="swap" PARTUUID="1fcaf589-217b-4846-a6bc-7cbf860aca96"
/dev/sda4: LABEL="Operating System" UUID="695f4ae8-e03f-4cf3-bc07-924c4cf57663" TYPE="ext4" PARTUUID="105224a8-b436-4378-9746-70bc5ebaa77e"
$ cat /etc/fstab
UUID=695f4ae8-e03f-4cf3-bc07-924c4cf57663 /               ext4    errors=remount-ro 0       1
#/dev/mapper/cryptswap1                    none            swap    sw                0       0
UUID=BE0A-CB90  /boot/efi   vfat    defaults    0   1
UUID=e3a1dc8a-52d3-4cb4-ab5a-4ecf745a10f5 none swap sw 0 1

Snippet of dmseg:

[    8.787728] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   97.902641] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   97.902645] Bluetooth: BNEP filters: protocol multicast
[   97.902651] Bluetooth: BNEP socket layer initialized
$ fdisk -l
Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1050623   1048576   512M EFI System
/dev/sda2  233291776 250068991  16777216     8G Linux swap
/dev/sda4    1050624 233291775 232241152 110,8G Linux filesystem
2
1

/etc/crypttab Here, I found an entry that referred to the non-existing cryptswap. I deleted it.

Got it from: Ubuntu 16.04 boot slow

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.