1

I am having issues with the Ubuntu 16.04.

Using:

  • Dell XPS L502
  • i7-2630QM Quad Core
  • Linux 4.4.0-36-generic
  • Nvidia GT540M (have the proprietary driver installed 361.42, and bumblebee)

The CPU core temperature is always over +76.0°C and the fan is always ON. The GT540M is also at 75+ temperature.

I have installed TLP, Intel Powertop, and have the Laptop optimized the for powersave mode.

Sometimes when I restart, the laptop cools down and I do not have any issue until the next restart. I have gone days without restarting. But this is seriously bugging now. Sometimes even simple videos on VLC start the fan, and then it will not turn off until I restart an arbitrary number of times.

Is there any other solution I should try?

Edit: Solved. Turns out you do not need tlp/powertop/etc. (although you might use them for even more optimized performance).

The only thing you need to do is install nvidia drivers (easiest way from additional drivers). Then open up the Nvidia X Server Settings (from dash) and change the PRIME profile to Intel (power saving mode).

Haven't had any issues since changing that setting (around a month).

0

If your computer is in a dusty environment, the cooling fan can have reduced efficiency, or stop working all together. Also, the thermal paste that is in between the processors and it's cooling mechanism needs reapplication if it's old and not conducting as much heat away from the processors as it did when it was new. If you're not willing/able to remove the bottom cover from the laptop to check/clean the cooling fan, at least take a vacuum cleaner with an exhaust port, and with the machine powered off, blow air into the laptop via the vents to try and force out any dust.

Software wise, I'd remove tlp, and try this.

First, make sure that intel-microcode is installed. This will make sure that the processors are up to the latest revision. After installation and reboot, in terminal, you can type dmesg|grep microcode to see its operation in updating the processors.

Then I'd install thermald to see if that helps regulate the temperature better. It comes with a default config file that should work on most machines, but I wrote my own custom config file tailored to my Toshiba i5 laptop. You'll want to read up a little on thermald by typing man thermald and man thermal-conf.xml, in terminal. You can run thermald manually in --no-daemon mode to watch if it's doing the right thing, or as a basis for writing your own custom config file.

Let us know if this helps. Cheers, Al

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.