0

I just received a new Dell Latitude E5570 for work and installed Ubuntu Gnome on it. I quickly realized that it was only running at 1366x768, rather than the 1920x1080 it should be capable of. In the list of resolutions, it is not showing anything higher than 1366x768. I've already had to install kernel 4.7 in order to get Ubuntu running properly, so I suspect there might be some issue with the newer hardware. Is there anything I can do to find a solution?

Edit: I have tried the solution listed in the suggested duplicate, and when I try to addmode I get:

➜  ~ xrandr --addmode eDP1 1920x1080_60.00                                                            
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  47
  Current serial number in output stream:  48
2
  • I wish it were that easy. That solution doesn't work in this case, which would not normally be enough to consider it not a dupe, but it's also for a very different version of Ubuntu, which could certainly play a factor. – SaintWacko Sep 16 '16 at 22:22
  • How did you determine the cvt parameters for your screen? – Elder Geek Sep 16 '16 at 22:42
2

According to Dell that model is sold with 3 different screens which vary by country and configuration. Since one of the screens listed matches the resolution you are getting and your getting invalid parameters on the xrandr line I can only assume you have the first one listed.

15.6” HD (1366 x 768) Anti-glare (16:9) WLED, 200 nits, Carbon Fiber Reinforced Polymer LCD Back

I know this isn't the answer you wanted, but at least it's accurate

Source: http://i.dell.com/sites/doccontent/shared-content/data-sheets/en/Documents/NA-Latitude-15-5000-Series-E5570-Spec-Sheet.pdf

1
  • I had been told by my company's technical team that they were only able to order it with one screen (the 1920x1080) and shown a screenshot proving it. However, after popping in a Windows 10 hard drive and installing the proper drivers, I have to conclude that this one somehow ended up with the screen listed here instead. – SaintWacko Sep 17 '16 at 23:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.