28

On the prior version of Chromium the Chromecast extension could find my Google Chromecast v2 devices. Now it can't and it says it can not find any devices when I try to cast. What's going on and how to I fix it?

34

Works at least with Version 55.0 (the version shipped with 16.10).

So there are two ways to cast to Chromecast

  • one of them is with the extension
  • the other one is with the native functionality.

This should work natively with Google Chrome.

I do not believe Chromium supports the native cast. Disabling this native feature opens up the ability to use the extension. Or you can use Google Chrome.

  1. Open up chrome://flags/#media-router, it should say Media Router Mac, Windows, Linux, Chrome OS: Enables Chrome to access external presentation-type displays and use them for presenting web content. #media-router
  2. Change it from Default to Disabled
  3. Restart chromium-browser
  4. Install Google Cast extension if necessary

This should work. There is a Launchpad bug opened here. The answer is based off Bob Smith's suggestion on this Debian bug. You can now see this advice in the official faq How to turn off Media Router and use the Google Cast extension.

| improve this answer | |
22

I am using chromium Version 57.0.2987.98, Ubuntu 17.04 (64-bit). The native "Cast..." does not work until you enable this flag below. Once its enabled, it works perfect, no need for any extension.

chrome://flags/#load-media-router-component-extension

| improve this answer | |
  • yep, works for me on debian 8.7 with chromium 57.0.2987.98. The other answer said to disable, but i found that only enabling the property you list works. – mulllhausen May 21 '17 at 10:42
  • Ubuntu 16.04 LTS with Chromium 58.0.3029.110 confirmed solution. – s3m3n Jun 13 '17 at 14:11
  • This also works for me on Gentoo and Chromium 59.0.3071.104. I'd note that I had to change the setting from "Default" to "Enabled" and restart the browser. – David Z Sep 13 '17 at 5:44
  • Confirmed on Slackware64-14.2 and Chromium Version 62.0.3202.75 (Developer Build) (64-bit). This appears to be the correct answer as of February 2018. – YellowApple Feb 21 '18 at 1:28
  • I also had to enable #media-router-cast-allow-all-ips for my Chromium 74.0.3729.131 to work. – Waldir Leoncio May 13 '19 at 19:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.