1

I am on Ubuntu 16.04.1 using Gnome as my DE and WM. With the gnome tweak tool, I have made it so that when my laptop lid is closed with an external display, nothing happens. When I close my laptop lid, there is no audio output at all. I suspect it is something to do with pulse audio. Can anyone help me?

Edit: There is no audio output from any source(speakers or headphones). I am quite new to ubuntu, so please do tell me how to give you my sound settings. I was just speculating that it might have been a pulseaudio issue. With gnome-tweak-tool, i went under the "power" section and enabled "do nothing" when laptop lid is close and power is plugged in.

  • Please edit your question to provide further useful information. No audio output from where? (internal speakers, analog headphone jack, HDMI)? What are your sound settings? Why do you think it's related to pulse audio and not ALSA? Specifically what setting(s) did you change with gnome-tweak-tool? Please help us help you! – Elder Geek Sep 16 '16 at 21:40
  • @ElderGeek Hey, I have edited the post. Thanks for helping out – WhosSu Sep 16 '16 at 22:11
  • You mention an external monitor. How is that connected? is it via HDMI? – Elder Geek Sep 16 '16 at 22:14
  • @ElderGeek Yes, I am on a dell xps 13 (9343) – WhosSu Sep 16 '16 at 22:18
  • When you close your lid your wireless keyboard, wireless mouse and external monitor all behave normally but there is just no sound to ____? Was the sound coming from your laptop speakers before lid close? Can you navigate to System Settings, Sound and see the various sound devices? Can you click on them? Please update your question with this information. – WinEunuuchs2Unix Sep 17 '16 at 1:02
0

If all else fails you might wish to get support from http://www.dell.com/support/home/us/en/04/product-support/product/xps-13-9343-laptop/manuals

I checked the certified models and your is listed as certified (as Pre-installed by the manufacturer for 14.04), it's not certified for 16.04

  • I am using pulse audio instead of alsa, and the volume levels is definitely not the problem. I encounter this lack of sound when my lid is closed. However, if i open the lid of my laptop the sound automatically returns. – WhosSu Sep 16 '16 at 22:47
  • Well it appears the gnome tweak tool is stopping it from hibernating/sleeping, but there's no telling what else dell tied to that pin switch. I would contact the manufacturer and ask some specific questions... – Elder Geek Sep 16 '16 at 22:59
0

I had this problem until I installed 3.19.0-66-generic. Needs linux-image-extra and DKMS to get wifi to work. This version still does not detect the headphones correctly but at least I don't need to put the computer to sleep through the power button. Saves a little time.

  • 1
    Ubuntu 16.04.1 uses kernel-version 4.4.0.38. I don't think it's possible to downgrade that much...Please read questions carefully before posting an answer. – mook765 Sep 29 '16 at 17:40

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.