Wifi generally works well, but there are times when it slows down considerably or completely disconnects. This happens randomly, and I don't have such problems in Windows 10. I'm wondering if there is something wrong with the r8169 driver? I read that it could be troublesome. The problem seems to fix itself after restarting, booting into Windows, restarting again, and then booting into Ubuntu. I'd like a more permanent fix, though.

I tried replacing r8169 with r8168 but I was not able to use r8168 because it said the module could not be verified and there was a missing required key.

sudo lshw -C network
       description: Wireless interface
       product: RT3290 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlo1
       version: 00
       serial: 48:5a:b6:bb:75:45
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=4.4.0-36-generic firmware=0.37 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:f0210000-f021ffff
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eno1
       version: 07
       serial: a0:1d:48:d9:db:8e
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:34 ioport:2000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff memory:f0010000-f001ffff
eno1      Link encap:Ethernet  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:470 errors:0 dropped:0 overruns:0 frame:0
          TX packets:470 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:47156 (47.1 KB)  TX bytes:47156 (47.1 KB)

wlo1      Link encap:Ethernet  
          RX packets:3772 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3533 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2824750 (2.8 MB)  TX bytes:633420 (633.4 KB)

lo        no wireless extensions.

wlo1      IEEE 802.11bgn    
          Mode:Managed  Frequency:2.442 GHz     
          Bit Rate=7.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=42/70  Signal level=-68 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:187  Invalid misc:628   Missed beacon:0

eno1      no wireless extensions.
  • 1
    your wireless driver=rt2800pci Your ethernet (wired) uses driver=r8169 driverversion=2.3LK-NAPI. You are researching the wrong driver. – Elder Geek Sep 16 '16 at 21:46
  • So then the rt2800pci driver is causing the issue? Are problems with this driver widespread? How can I fix it? – thewire Sep 16 '16 at 23:52
  • Yes, Not that I'm aware of, I'll have to look – Elder Geek Sep 16 '16 at 23:55
  • 1
    Possible duplicate of Slow wireless with rt2800pci – Elder Geek Sep 16 '16 at 23:58
  • I read that NetworkManager periodically scans for networks and that's what causes issues with some drivers. Could that be it? – thewire Sep 17 '16 at 1:10

The drivers you refer to have nothing to do with a wireless problem.

If you're having ethernet problems, you should replace the buggy r8169 driver with the r8168-dkms driver from the repositories, AND turn off secure boot in the BIOS.

Cheers, Al

  • I did turn off secure boot, and I did install the r8168 driver, but I was unable to use it. It said "r8168: module verification failed: missing required key" – thewire Sep 16 '16 at 23:50
  • Recheck your secure boot settings in your BIOS, because turning that off will fix your missing required key error. Cheers, Al – heynnema Sep 16 '16 at 23:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.