3

When I try to install some graphics-related packages like libdrm-dev, I get strange errors:

$ sudo apt-get install libdrm-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libdrm-dev : Depends: libdrm2 (= 2.4.67-1ubuntu0.16.04.2) but 2.4.68+git1606141830.625d18~gd~t is to be installed
              Depends: libdrm-intel1 (= 2.4.67-1ubuntu0.16.04.2) but 2.4.68+git1606141830.625d18~gd~t is to be installed
              Depends: libdrm-radeon1 (= 2.4.67-1ubuntu0.16.04.2) but 2.4.68+git1606141830.625d18~gd~t is to be installed
              Depends: libdrm-nouveau2 (= 2.4.67-1ubuntu0.16.04.2) but 2.4.68+git1606141830.625d18~gd~t is to be installed
E: Unable to correct problems, you have held broken packages.

If I'm reading this correctly, it looks like libdrm-dev depends on other packages, like libdrm2, but an older version is installed and it requires a newer version. Why is an error being thrown instead of these newer versions being installed? How do I install this package?

I get this error on both Ubuntu 14.04 and 16.04.

2

1 Answer 1

2

You are using those libdrm* packages from a PPA that doesn't provide the matching -dev packages (probaly ppa:oibaf/graphics-drivers).

Ask the owner of the PPA to provide the missing -dev packages or remove the PPA and downgrade to the official libdrm* packages.

2
  • 1
    That ppa does provide libdrm-dev for xenial though the current version is advanced from what the Op is showing. Most likely they installed from that ppa then disabled the ppa later. (or haven't updated sources in quite some time, the former is most likely) As far as trusty it would appear the ppa no longer supports & then removed all trusty builds which is unfortunate to those previously using.
    – doug
    Sep 17, 2016 at 3:35
  • 1
    @doug, Yep, that's what happened. The bigger problem was using apt-get, which gives you a useless error message. When I used aptitude to install, it explained the real issue and presented me with an option to downgrade, and the install succeeded perfectly.
    – Cerin
    Sep 17, 2016 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.