2

I installed deluge, deluged and deluge-console. All of them work fine and I can start the deluged daemon using this command

$ deluged

but I cannot start it using the init.d script that comes with it. Neither of these work:

$ sudo service deluged start
$ sudo /etc/init.d/deluged start

and if I check the status, it says active (exited). This worked without any issues on my previous laptop running ubuntu 14.04, but doesn't on my fresh 16.04 installation.

I've tried everything I could think of; tail logs (they're empty), change permissions and mask (didn't do anything), change auth settings - but it just doesn't start. I've been at this for over an hour, and any help would be highly appreciated. Installing a torrent-client shouldn't take this long.

4

Okay, so I got it working! I've been closely going over the /etc/init.d/deluged apparently the daemon mode of deluged is disabled by default (WTF deluge, what else is the point of installing a daemon) and you're supposed to enable it manually (they also forgot to mention this in the user guides).

Anyways, to enable it, open /etc/default/deluged in your favorite editor:

$ sudo vi /etc/default/deluged

and change ENABLE_DELUGED=0 to ENABLE_DELUGED=1

1
  • I have the same symptoms, but already had ENABLE_DELUGED=1 ... No go. – Carlo Wood Dec 1 '16 at 17:16
0

As explained on the Deluge Service wiki you should be using systemd with Ubuntu 16.04.

Most Linux distributions now use systemd. See ​wikipedia for releases with systemd as default.

systemd 

Upstart (Ubuntu 11.04 to 14.10) 

init.d (Obsolete)

The init script is provided by the Ubuntu package maintainers but the /etc/default/deluged file is mentioned in the init wiki...

1
  • I like init.d more. And the init script in the wiki is very different than what comes pre-packaged with deluged. – Sheharyar Sep 26 '16 at 13:08
0

After adding 'VERBOSE=yes' to /etc/default/deluged, I got the warning message:

$ sudo /etc/init.d/deluged start
[....] Starting deluged (via systemctl): deluged.serviceWarning: deluged.service changed on disk. Run 'systemctl daemon-reload' to reload units.
. ok

And after running sudo systemctl daemon-reload the daemon was indeed running.

Note that my /etc/default/deluged now looks like this:

# Defaults for deluged initscript
# sourced by /etc/init.d/deluged

# change to 1 to enable daemon
ENABLE_DELUGED=1

# Added by carlo. Run the daemon as user 'deluge' instead of 'debian-deluged'.
DAEMON_ARGS="-d -c /var/lib/deluge/.config/deluge -l /var/log/deluge/daemon.log -L info"
USER=deluge

The reason I need the daemon to run as user 'deluge' is because the client runs as user 'deluge' and they share the same config directory. That is, the 'auth' file in both need to be the same, and for the rest it is TOTALLY unclear which files are used by the daemon and which are used by the client :/. I tried hard to get it to work using two different users but in the end BOTH also need read/write access to where ever the torrents are put, the data is downloaded to etc. In the end I ended up adding both users to eachothers groups and then using chmod g+s on all directories in the torrent/data tree, which makes the two users so equivalent that it didn't make any sense anymore to have two different users in the first place AND it STILL didn't work (all my torrents where in 'Error' state). So, I gave up and just went back to using a single user for deluge.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.