I'm having an odd problem related to the graphics card and drivers in my laptop.

The Background: This machine is a Lenovo ThinkPad T530 with a discrete NVidia NVS 5400M graphics card running Ubuntu 14.04.5 LTS I'm running some applications that could benefit from the discrete GPU so I turned it on and installed the NVidia driver via the "additional software" option in the "Software and Updates" menu. The driver I selected was:

Version 352.63 from nvidia-352 (Proprietary, Tested)

This appears to be working, but results in some odd start-up behavior.

The Problem: At boot the familiar Ubuntu loading screen appears but when the login page starts to display the screen turns off. Due to various indicator lights, sounds, etc. I know the login page is still up and I can successfully log in. The screen is not frozen or displaying a black page, it's just off.

Quite by accident, I made the discovery that if I wait long enough for the screen to turn off from not being used I can wake it up as if that's all that was going on. (My laptop has a fingerprint reader. When it goes to the login page the green LED on the reader turns on to indicate it's ready for my fingerprint/password.)

As I'm not a big fan of waiting 10 to 15 minutes for my laptop to become usable I am hoping that one of you can help me determine the cause of this behavior as well as a possible solution. I suspect that some power-saving function in the driver is the culprit, but I have no knowledge of how to test it.

I'm tolerably proficient in ubuntu, so I can get any information you think you may need to help me. I just don't know what that might be.

Note: I've tried Bumblebee and I have the same problem. That's not going to fix it. I've also tried using the "X.Org X server" driver and the drop in performance is pretty noticeable. I can use that if it becomes my only option but I'd really like to solve this problem. Also, I don't see how it's relevant but the software I'm trying to use the GPU with is Gazebo and RViz with ROS Indigo. Without the GPU running the framerate in RViz falls from about 35fps to 2 or 3 fps.

Edit on 9/18/16:

I tried installing two different nvidia drivers using these instructions. I installed the nvidia 361 and then later the nvidia-370 drivers. Both drivers responded the same way as the *-352 driver.

I've gone back to using the X.org x server driver as this does not have this problem. However, I would still like to use the nvidia driver for the added performance it yields.

  • I read something last night that might be relevant but I'm on my phone now. In the mean time before your next shut down change your sleep time out from 15 minutes to 1 minute and then back to 15 after next login. Keep repeating so you don't wait so long for boots. Sep 16, 2016 at 19:47
  • I just realized that my other ubuntu install on the same computer (16.04) does not exhibit this behavior. It's running the 361.42 nvidia driver. For some reason I though it was using X.org X server drivers. I'm going to try changing my 14.04 install to that driver and see if it resolves the issues. I'll report back with my success/failure.
    – rkforde42
    Sep 18, 2016 at 18:07
  • @rkforde42 any news? did it work?? :/, see here: askubuntu.com/questions/901001/… Apr 7, 2017 at 0:03
  • I've mostly given up at this point. I'm not using 14.04 much anymore (ROS was the only software package holding me back, and we updated the robot using to a new version that supports the new versions of ubuntu.) and I've not had this problem in the 16 or 17 releases. Not sure why nor do I have the time to figure it out. I wish you the best of luck with your issue.
    – rkforde42
    Apr 16, 2017 at 4:43


You must log in to answer this question.

Browse other questions tagged .