4

The behaviour I would like to disable is shown in the following animation.

GIF animation

  • I seem to found when they introduced it. I didn't have Nautilus, but you could try checking configs at ~/.config/nautilus directory for relevant timeouts. – Hi-Angel Sep 16 '16 at 19:15
3

It has been reported as a bug in various places, and a topic of multiple discussions:

Although the current direct solution is to re-compile from a modified source, many recommendations have been made to the Nemo file manager: http://www.webupd8.org/2013/10/install-nemo-with-unity-patches-and.html

Nemo will fix the problem you have, but it won't be the actual nautilus, as it was a fork from an earlier version.

It seems fairly easy and painless to install, so giving that a try may be your best solution currently. (Assuming you don't want to rewrite and recompile nautilus. I don't have personal experience with Nemo.)

Your bug should be fixed in the future though, if the bug reports are of any truthfulness.

| improve this answer | |
6

As of Nautilus version 3.17.91, this bug has been fixed by adding an option to disable the "auto-open" behaviour. From the NEWS file:

Major changes in 3.17.91:
...
* Add a preference and disable by default automatic opening of folders while hovering on drag an drop operations (Carlos Soriano)

The default was subsequently changed to "enabled", restoring the "auto-open" behaviour for anyone who doesn't disable it explicitly.

Unfortunately this change wasn't in time to make it into Ubuntu 16.04, which ships with Nautilus 3.14.3. Ubuntu 16.10 shipped with version 3.20.3, so it and subsequent versions should have the option (at least until GNOME decide to remove it again in order to streamline the user experience).

I don't know whether this option is exposed in the GUI, but would expect not. In any case it should be possible to disable the behaviour from the command line with

gsettings set org.gnome.nautilus.preferences open-folder-on-dnd-hover false
| improve this answer | |
  • Sadly the version on Ubuntu 16.04 LTS is still 3.14.3 which means this setting isn't available (yet). Yet another reason to switch my DE from Unity to something else (anything else). – dragon788 Mar 29 '17 at 1:23
  • 1
    On Debian Stretch, nautilus v3.22.3 there is no GUI option (that I can find), but applying the setting with gsettings worked great! Bash completion even works for it. Thank you! You just reduced my stress level. – Drew Chapin Jan 26 '19 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.