6

I've had a strange issue with an Ubuntu 14.04 server installation recently, and would like some pointers to diagnose the cause of the problem.

The OS will not boot unless a monitor is connected via the VGA port.

I believe that the boot process may be stalled at the grub menu, as the server turn off immediately when the power button is pressed, whereas power off when the OS is running takes a few seconds through the normal ACPI process.

As the OS isn't starting, there are no logs to guide me through a debugging process. What can I do to begin to understand where the problem lies?

3
  • do you have a GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" in /etc/default/grub? – Rinzwind Sep 16 '16 at 11:45
  • No, I was wondering if it may be related. – Arronical Sep 16 '16 at 11:45
  • 1
    Yes it probably will be what you are missing. If so: pm me and Ill make it an answer. Oh what the heck. Made it an answer/ – Rinzwind Sep 16 '16 at 12:18
6

Make a backup of /etc/default/grub and then edit the file with ...

sudo nano /etc/default/grub

and then find the line ...

GRUB_CMDLINE_LINUX_DEFAULT

and remove quiet and splash if they are there (doubt that they are cuz otherwise it would never work) and add ...

nomodeset

From comments for you this would be

  GRUB_CMDLINE_LINUX_DEFAULT="biosdevname=0 nomodeset"

You will need to do a

sudo update-grub

to reload grub. A reboot should let the system pass grub without a monitor.

4
  • Thanks for the suggestion, I already have GRUB_CMDLINE_LINUX_DEFAULT="biosdevname=0" to use traditional eth0 type naming for network interfaces, how do I work around that? – Arronical Sep 16 '16 at 12:24
  • 1
    @Arronical I think you can simply put both on the line: GRUB_CMDLINE_LINUX_DEFAULT="biosdevname=0 nomodeset" – alci Sep 16 '16 at 12:29
  • 1
    then add this to it @Arronical – Rinzwind Sep 16 '16 at 12:32
  • I'll test and accept if it fixes the issue. Thanks again – Arronical Sep 16 '16 at 12:42
4
+25

This is quite likely a hardware issue and not related to the OS

Many older motherboards, especially non-server ones require a connected monitor on boot during the P.O.S.T sequence otherwise the motherboard will halt during the boot sequence never reaching the boot loader.

This often unfortunately holds true even if you enable the Don’t halt on Error option in the Bios.

Since a small amount of current is sent through the pins to check for connectivity you can make a dummy connector by simply connecting three 50-100O Ohm resistors between the pins shown below

enter image description here

That's how I solved this issue with a "server" I had ;)

2
  • Nice, but my Dell Precision Tower 5810 , Xeon E5, last updated BIOS with a HDMI monitor connected to a Nvidia Quadro K420 should not be expected to present such issues :) – Patrizio Bertoni Sep 19 '17 at 6:49
  • My problem with this is on quite new hardware, but this alternative method is definitely interesting to know. – Arronical Sep 19 '17 at 8:12
0

For HDMI you can buy a HDMI dummy plug,Headless Ghost, Display Emulator from Amazon or elewhere. HDMI Headless Plug

0

@Rinzwind's answer worked for me in part. I also had to uncomment GRUB_TERMINAL=console in /etc/default/grub to have a headless ubuntu server install on my system.

Note this change made it so that my computer no longer booted with a monitor plugged in(!) Make sure your system is ssh ready before making this change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.