0

I'm trying to setup ubuntu 64 bit VM on my stupid windows 7 machine.

The Network information that the Windows is connecting to

enter image description here

enter image description here

Wireless LAN adapter IPv4 of the host machine - 10.11.209.93

Ethernet adapter VB Host-Only IPv4 - 192.168.56.1

I enabled virtualization in BIOS settings.

windows Host only configs

enter image description here

And, I also set the VirtualMachine network provider to be Bridge Adaptor.

Also, have network sharing [which is not needed actually]

enter image description here

enter image description here

But, there's no connection in the ubuntu VM.

ifconfig

    enp0s3 Link encap:Ethernet  HWaddr 00:2D:32:3E:39:3B
          inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::48:817c:1b4d:e85a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:56 errors:0 dropped:1990 overruns:0 frame:0
          TX packets:169 errors:8 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7409 (7.4 KB)  TX bytes:16785 (16.7 KB)

    lo   Link encap:Local Loopback  
         inet addr:127.0.0.1  Mask:255.0.0.0
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:50121 errors:0 dropped:0 overruns:0 frame:0
         TX packets:50121 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1 
         RX bytes:17079(7.4 KB)  TX bytes:16785(17.0 KB)

resolv.conf

$ cat /etc/resolvconf/resolv.conf.d/head                   

    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) 
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

$ cat /etc/resolv.conf
    nameserver 127.0.0.1
    search shaharma.net

ping google.com just hangs on ubuntu VM.

I tried adding nameserver 8.8.8.8 too but does not work either.

Refs

How to share internet access between Ubuntu and Windows guests OS in VirtualBox?

12.04 on VirtualBox -No internet access on Guest OS

How-to: VirtualBox Networking Part Two - NAT and Bridged

1

Your resolv.conf looks wrong. The DNS server can't be 8.8.8.8.4.4.4.4. Somewhere you entered a list of DNS servers, but you forgot the comma between the server addresses (ie: 8.8.8.8, 4.4.4.4). Probably did it in the connection script for your network connection. Go to the network icon in the top panel, and choose Edit Connections.... Locate and edit the network connection and add the comma, and restart your VM.

update: Your VM settings should include Bridged Adapter. Internet Connection Sharing should be off. Your enterprise network may give you trouble too... if so, talk to your network administrator for more help.

Let us know how you do. Cheers, Al

  • sorry that was my STUPID typo. Can you please check that. It's killing me, as I'm trying to work on linux machine, but its taking forever to fix it. – prayagupd Sep 16 '16 at 18:20
  • What is the IP address of your host machine? In the VM, can you ping 8.8.8.8? Can you ping www.ebay.com? Turn off Internet Sharing. Don't edit resolv.conf. Cheers, Al – heynnema Sep 16 '16 at 18:42
  • ps: In Windows, do you connect to the Internet via ethernet, or wireless? Cheers, Al – heynnema Sep 16 '16 at 18:48
  • Wireless LAN adaptor IP of the host machine - 10.11.209.93 and I'm connecting to internet in host machine via Wireless. – prayagupd Sep 16 '16 at 20:21
  • Somewhat strange IP. Do you have a wireless router/modem supplied by the Internet provider, or did you supply your own wireless router? You didn't answer the ping questions. The IP of the VM should be something like 10.11.209.nnn. Change the bridge setting back to original eth0, reboot VM, note the IP address with ifconfig, and try Internet again. Turn Internet Connection Sharing off. Let me know. Cheers, Al – heynnema Sep 16 '16 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.