Recently, I've tried to install Gitlab Enterprise Edition on my WSL system as I lack a proper development environment at the moment.

The install itself goes reasonably well, but I cannot configure Gitlab (gitlab-ctl reconfigure), as it returns this error:

  * service[create a temporary mailroom service] action nothing (skipped due to action :nothing)
Recipe: runit::upstart
  * cookbook_file[/etc/init/gitlab-runsvdir.conf] action create (up to date)
  * execute[initctl reload-configuration] action run
    [execute] initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

    Error executing action `run` on resource 'execute[initctl reload-configuration]'

    Expected process to exit with [0], but received '1'
    ---- Begin output of initctl reload-configuration ----
    STDERR: initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
    ---- End output of initctl reload-configuration ----
    Ran initctl reload-configuration returned 1

Attempting to force initctl to return true (using ln) causes even more problems than it solves, so it's really not an option.

Is there anything I can do to get Gitlab working?

  • WSL using 16.04? – Anwar Sep 15 '16 at 5:08
  • 1
    @Anwar WSL seems to only use 14.04. At least, it is 14.04 on my install. – Kaz Wolfe Sep 15 '16 at 5:08
  • WSL definitely uses 14.04 for now. I have seen people do this to upgrade to 16.04 though. – edwinksl Sep 15 '16 at 5:28
  • You might have an advice here? askubuntu.com/questions/905658/… – JohnDoea Apr 17 '17 at 5:31

I fear, I don't have any good news for You. It seems WSL still doesn't work with upstart, initctl things which start jobs upon booting machine. There was a similar issue reported on Github.

Quoting aseering from that issue

WSL doesn't use Upstart to start processes at system boot. If you work closely with Upstart, this might cause some surprises for you; the message is informative to people who work directly with initctl, upstart, etc that WSL doesn't yet expose that functionality.

furthermore, He pointed out that WSL is really a beta release yet and this kind of errors aren't unexpected.

WSL is beta software in this release. Some companies of late have had "beta" releases that are really production-ready. But WSL really is traditional beta software: There are many things that it does correctly; there are also many things that are still in progress so don't work yet. It's typical to hit messages such as this one, or to encounter tools that don't completely work yet, etc.

The issue is still open. My suggestion would be go and comment on that issue about your problem, so that they fix the issue soon.


Is there anything I can do to get Gitlab working?

Yes. Forget about upstart entirely. You're using upstart to run runit, which in turn is what is supervising the gitlab service(s). Upstart is an entirely unnecessary part of this on the Windows Subsystem for Linux.

Get runit itself running on the Windows Subsystem for Linux. (You might have to tweak it as it has known package problems even on Ubuntu Linux.) Then simply use it directly to manage your gitlab service(s).

Further reading

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.