0

I have Ubuntu 14.04 LTS and a HP Spectre x360 machine.

I am trying to get Skype to work but I always have the same problem - once I put my webcam on, it goes crazy and flashes blue and my self-image is only a close up up my eyes!

Someone suggested the new Skype for Linux alpha - but there is no video calling on that.

I'm new to Linux and just wanted someone to explain what the deal is with Skype. Am I wasting my time trying to get Skype to work on Ubuntu or is it possible if I find the right version?

Thanks.

  • 1
    Skype for Linux hasn't been updated since 2014, and is slowly losing functionality, as Microsoft is implementing new protocols. It's very probable Skype for Linux can't do video calls anymore, because of the lack of updates. Make sure your camera works in another app, like Cheese. If it does, it's Skype that's the issue, and unfortunately, you're probably going to have to wait for Alpha to complete. – TheWanderer Sep 14 '16 at 23:57
  • 1
    Skype in Ubuntu may not be great but it can work correctly with the camera if the drivers work. You can test with a usb camera if you have one or make sure that the drivers are correctly installed. This may help help.ubuntu.com/community/Webcam – Katu Sep 15 '16 at 8:10
  • The webcam works fine with cheese. I've tested it on webcam test websites too and it seem okay. It's just doesn't work with Skype. How do Linux people video chat? – user1551817 Sep 20 '16 at 14:48
0

What worked for me was using the nomodeset option in the grub bootloader. There are two methods to set nomodeset:

  1. Temporary:
    • While booting press and hold shift in order to see the grub menu
    • Choose the entry you want to change (in a normal installation the first entry) and press e to edit it
    • Look for quiet splash and add nomodeset before it
    • Finally press F10 to boot.

If this worked for you, you can use the permanent way for all bootups.

  1. Permanent:
    • edit /etc/default/grub (for example: sudo nano /etc/default/grub)
    • change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash"
    • Finally update the grub config: sudo update-grub

The next time rebooting, you don't have to specify the boot option.

I run Ubuntu 16.04 LTS with 4.4 kernel on Lenovo i310 laptop.

The output for sudo lshw | grep -A9 VGA is the following:

description: VGA compatible controller
product: Sky Lake Integrated Graphics
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 07
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: latency=0

This answer is partially copied from last answer at When I start my camera in video call on Skype 4.1. incoming video is flashing blue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.