2

I have added the following line to my /etc/fstab (with the correct IP...):

123.234.123.234:/folder /home nfs defaults 0 1

Typing as root mount -a mounts the drive, but after reboot I have to mount it manually again. On my other computers, it always works after reboot.

What can the problem be? PC is under Linux Mint 17 (~ Ubuntu 14.04).

1
3

The possible culprit is that your network might not be available when the system is processing the fstab. I believe auto is the default but would encourage you to add it. Also add delay_connect to give time for the network to come fully up.

According to the mount manual the defaults options are rw, suid, dev, exec, auto, nouser, and async. So you can replace what you have and itemize the defaults while adding the delay_connect option.

123.234.123.234:/folder /home nfs rw,suid,dev,exec,auto,nouser,async,delay_connect  0 1
1
  • 1
    Your solution did not work, however 123.234.123.234:/folder/home nfs _netdev 0 0 seems to do the trick. – anderstood Sep 22 '16 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.