1

I just read this article: http://bernaerts.dyndns.org/linux/74-ubuntu/343-ubuntu-install-hp-stream-13

I put Ubuntu 16 on my HP Stream 13 with a CD/usb. I'm having trouble getting the wifi to work though. The wifi adapter on my machine is a Broadcom BCM 43142 802.11bgn.

I downloaded the driver I found online via an ethernet cable. I installed it from my Downloads folder with

sudo apt-get install bcmwl-kernel-source

and I now see a wireless symbol at the top of my screen, but it's not working. When I click the symbol it says "No network devices available". Also, when I boot the computer now I get 3 error messages that say "System program problem detected" and ask if I want to report the problem.

Help?

Edit: When I type in:

lspci -knn | grep Net -A2; rfkill list

I get:

02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

    Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n [103c:2230]

    Kernel modules: bcma, wl

0: hci0: Bluetooth

    Soft blocked: no

    Hard blocked: no

marked as duplicate by Pilot6, Community Sep 15 '16 at 16:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please edit your question and add output of lspci -knn | grep Net -A2; rfkill list terminal command. – Pilot6 Sep 14 '16 at 21:23
  • k done. now what? – fariadantes Sep 15 '16 at 3:42
  • Now disable Secure Boot in BIOS. – Pilot6 Sep 15 '16 at 8:34
  • That fixed the problem! Thank you, I now have wifi. Those error messages on startup disappeared too. – fariadantes Sep 15 '16 at 16:48
0

It could be the hardware switch on your computer. It's labeled as WLAN and if it's off your computer will not be able to connect wireless to the internet. So switch it on and that should fix the problem.

  • how can i do that? – fariadantes Sep 15 '16 at 3:34
  • Are you on a desktop or laptop? – Hershey Gamer Sep 16 '16 at 20:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.