1

I have a huge problem which has been adressed often: My launcher, panel, etc. is gone.

My system is Ubuntu 16.04 (on a notebook) and I was installing some themes (flatabulous, paper, arc, also installed ubuntu-tweak-tool and gtk-theme-config) and I don't know what exactly triggered it, but before I noticed the launcher and menu panel was gone.

I should note that my laptop was connected to my TV (and I put the display on the TV only) and I set the display to be scaled by a factor (1.35) on the TV and now that I have disconnected the TV, on the built-in monitor, the display still appears scaled! I tried reseting the scaling via system settings, but that doesn't work. Weird thing is also that when I login, the mouse stays at normal size for few moments and then gets enlarged now!

It gets wierder: When I login as a guest, the launcher and everything appears as it should (with correct scaling)! Also, when I type "unity" or something similar in the terminal, the menu panel appears for a second before disappearing again! It seems like something is overriding the unity or something like that.

What I have tried so far: All the 'dconf reset' and 'setsid unity' didn't work. I installed compiz-settings-things, tried enabling unity plugin (and enabled opengl, etc etc) and rebooted, and it didn't help. Also tried reinstalling ubuntu-desktop, unity, etc., no change. I'm slowly going crazy since I have the feeling I tried almost every solution I found via google. I also already uninstalled all themes I installed, but nothing changed.

If someone could help me, that would be GREAT! I'm going mad here T_T

EDIT: I could reset the scaling by installing unity-tweak-tool again and change the font scaling setting there, so the whole problem might be related to this tool (changing the unity settings doesn't do anything though). I also realize that I can't resize windows, only maximize them.

EDIT2 (Solved): I created a 2nd account (where unity worked without problems, of course) and compared the home directory of both accounts (the broken one and the new, normal, working one) and randomly deleted / renamed setting files and folders (the ones starting with "."; I clicked "show hidden files" before) in the broken directory which were different from the new account. Especially I also deleted the cache. When I logged back to the old account, suddenly the launcher (and panel) worked again. NO IDEA what exactly 'repaired' the problem, but for now, I'm just glad it works again. The icons on the launcher are reset, i.e. I have to dock my programs to it again, but I can definitely do that much.

7

I had the same problem, after a simple update apparently. "reset compiz" and "setsid unity" didn't work either. Inspired by the "method" above, I typed :

cd .cache
mv configcompiz-1 configcompiz-1_oops

then I rebooted and now it works : panel and launcher are back ! Thanks to you !

  • Could not comment on Fulbert's answer, not enough points. The above answer showed the fix, but compizconfig was mixed up as configcompiz. This should work: Open a terminal with a right click, you will find yourself in your home directory, from here: cd .cache mv compizconfig-1 compizconfig_renamed If all goes well, you can delete the folder later. – Stefan Schumacher Sep 16 '16 at 8:41
1

I installed updates this morning and after a reboot I had the exact same issue. After searching all over for an answer I came across this post. I used bleachbit to completely clear my user accounts cache folder and rebooted, Unity is back and working :)

1

Fulbert's answer worked to fix the ussue for me too:

  1. renaming /.cache/compizconfig-1 to /.cache/compizconfig-1_renamed;
  2. restart (unity panel and launcher reappear and a new /.cache/compizconfig-1 is generated by the system);
  3. delete /.cache/compizconfig-1_renamed

protected by Community Sep 21 '16 at 2:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.