2

I know I know, there are tons of questions regarding unrecognized screen resolutions, using xrandr, installing Nvidia drivers and related.

My new system is running Kubuntu 16.04, with kernel version 4.4.0-generic. It is a custom built computer, running an external video card, EVGA 1060 GTX 3GB model.

Following advices in this "guide": How do I install the Nvidia drivers? I was able to install the latest nvidia-370.

Now, on the ASUS monitor I am currently at (ASUS VS247H), the resolution should be 1920x1080, but only a maximum of 1024x768 is shown if running xrandr -q

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00*

Things I tried so far:

1)-------------------------------

The first thing that bothered me from the above was the line

xrandr: Failed to get size of gamma for output default

I tried some things, for example the first answer of this question here: "Fails to get size of gamma" error when trying to set resolution, which did not have any effect.

Then I realized that I had no file under /etc/X11/xorg.conf did not exist, and yet another answer at the site popped up: /etc/X11/xorg.conf doesn't exist?

Fazit: I tried generating my own as described in the first answer of this question: Where is the X.org config file? How do I configure X there? and then manually set a Screen with the correct resolution, without success.

2)-------------------------------

As mentioned in this guide about xrandr, I tried using

cvt 1920 1080 60
xrandr --newmode <output of the above>
xrandr --addmode HDMI1 1920x1080_60.00

But still, the above

xrandr: Failed to get size of gamma for output default

seems to be killing me.

  • 1
    Please edit your question to identify "the ASUS monitor I am currently at" This information may be helpful in determining what the root cause of your problem might be. Thank you for helping us help you! – Elder Geek Sep 17 '16 at 19:01
  • Sorry, forgot to mention. Will edit the post – titus.andronicus Sep 18 '16 at 15:46
1
+50

wow , nice graphics card !

its supported by the 367.27 which is supposed to be stable on day one according to phoronix.

http://www.phoronix.com/scan.php?page=article&item=nv-linux-gtx1060&num=1 

heres the nvidia driver ,

http://www.nvidia.com/download/driverresults.aspx/104284/en-us

but i'd recommend using the graphics-drivers-ppa version as it will be less fiddly to install and upgrade.

https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

There instructions on how to install on that page.

  • Thanks man! Not sure why, but when it was asking me to disable the UEFI mode it was not working before. Now I am on the 1920x1080 that I should have been from the beginning ;-) – titus.andronicus Sep 18 '16 at 19:58
  • there are apparently some issues with secure mode booting and nvidia cards , secure mode is a feature of UEFI. As i haven't found the actual cause i'm going to guess that its the requirement for secure boot to have a signed kernel images being difficult to statisfy with irregular binary driver releases that have specific distribution requirements. – Amias Sep 19 '16 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.