2

This question already has an answer here:

I would like to play games with better performance than what I'm getting after updating to Kubuntu 16.04 LTS. Half the games are unplayable, sometimes to the level of nauseating due to low fps. I'm not entirely sure if my open-source radeon drivers are working as they're supposed to.

I realize that AMD dropped support for proprietary fglrx drivers some time ago and they were deprecated in 16.04 due to incompatibility with the newer xorg.

My main question is:

Can I run games in a separate xorg environment using the older xorg version that still has fglrx driver support in Kubuntu 16.04?

Ideally in a way that other software (like browser or IM) would still be running and kind of accessible. Like on a separate tty or something. In the really perfect case none of that would have any GPU performance spent on it (so not rendered I guess).

Alternatively I'm interested of any other clues to increasing my performance.

I guess switching to Ubuntu 14.04 is one of my options at the cost of having most of my software be of older versions.


My GPU is AMD Radeon HD 7670M in a Dell Inspiron 15 (5520)

lspci -nnk | grep -i vga -A3 output:

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
        Subsystem: Dell 3rd Gen Core processor Graphics Controller [1028:056a]
        Kernel driver in use: i915
        Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] [1002:6840] (rev ff)
        Kernel driver in use: radeon
        Kernel modules: radeon
07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 05)

sudo lshw -c video output:

  *-display               
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:28 memory:c1000000-c13fffff memory:b0000000-bfffffff ioport:4000(size=64)

Asking any additional information is also welcome.

marked as duplicate by dobey, karel, Community Dec 15 '17 at 9:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

This may not work, so just bear that in mind.

You can try downgrading xorg on 16.04 to version 1.16, which works with fglrx. I know this procedure works on 14.04.5, which got the 16.04 xorg version and kernel, but I have not tested or gotten any confirmation that it works on 16.04 as well.

To install xorg 1.16:

sudo apt-get install xserver-xorg-lts-utopic libqt5gui5 libgles1-mesa-lts-utopic libgles2-mesa-lts-utopic libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libegl1-mesa-drivers-lts-utopic

You may have to uninstall the current version of xorg:

sudo apt-get remove xserver-xorg

but chances are it will be removed during the installation of 1.16.

Remember, I haven't tested this. I have gotten confirmation that it works on 14.04.5, but no one I know has tried it on 16.04 yet. It would be great if you are willing to test this. If you don't feel safe doing it, I will be happy to test in a virtual machine. (The fix if it doesn't work should be relatively easy: just reinstall xserver-xorg and the old version should be removed.)

  • Thanks! I tried several things. Some based off of your answer. Tried installing older kernel and older xserver-xorg, but ran into problems installing the actual drivers - there being no fglrx package in 16.04 repos. So I tried installing the proprietary drivers manually from AMD homepage - didnt succeed in it. Maybe that was just me. Eventually I solved my problem by installing 14.04 and not updating the kernel (which the Software Updater wants to do all the time, using apt upgrade instead). Since this isnt really the answer to the question I asked here, I shouldnt mark it as an answer. – Carolus Oct 13 '16 at 19:23
  • 1
    @Carolus users with AMD are advised to stick with 14.04 until AMD delivers proprietary drivers for 16.04 and 16.10. – Rinzwind Oct 13 '16 at 19:31
  • @Rinzwind Thanks. When 16.04 was released, I managed to miss that memo even though I dont live under a rock and I waited some months before upgrading. :D – Carolus Oct 13 '16 at 19:47
  • 1
    here is one omgubuntu.co.uk/2016/03/… – Rinzwind Oct 13 '16 at 19:53
  • Wow indeed. Anyway now there's the additional problem of 14.04 receiving updates to kernel and xserver which breaks fgrlx. One also gets these if one install 14.04.5. – Carolus Oct 13 '16 at 20:15
1

I don't know if it'll help, but I had a similar problem (an ARM Chromebook, the nvidia Tegra K1 video driver it ships with works with up through like Xorg 1.16 or 1.17, not 1.18.) I held back to Xorg 1.15 since that is what was on the system (as well as the kernel), I suppose you should pick latest Xorg fglrx supports. I realized if I looked at the ubuntu 14.04.x lts-vivid, lts-xenial, whichever has the xorg you want, the packages it gives a pretty complete list of packages to hold to have a particular xorg+mesa stack going.

I held back the following packages (this locks them to the currently installed version), had a successful update to 16.04 with a running old Xorg and no complaints about dependencies; and luckily no systemd-related problems either.

libegl1-mesa libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa
libgles2-mesa libvdpau-dev libvdpau1 libwayland-egl1-mesa 
x11-xserver-utils xorg xserver-common xserver-xorg xserver-xorg-core

Also

xserver-xorg-input-all xserver-xorg-video-all 

and the miscellaneous input and video drivers you have installed.

I held these with (sudo or gksu) apt-mark hold (package name) before I did the upgrade. Since you are already on 16.04, I think you could get the older versions (Ubuntu 14.04's lts-wily packages have xorg 1.17, original 14.04 has 1.15), install with dpkg, and then hold the packages. You can unhold a package with apt-mark unhold (package name) and dpkg --get-selections | grep hold lists what packages are held. If fglrx also needs an older kernel, it could be installed the same way.

Good luck!

  • After using 14.04lts for almost half a year, I'm quite fed up with outdated packages. I would try your solution, but rather than risking with having outdated kernel or breaking something, I'll just settle with the open-source drivers. I mean my performance can't get much worse than the 10-20fps right now, right? :D – Carolus Mar 10 '17 at 22:53
0

This worked for me in Ubuntu 16.04 Xenial

Download the AMDGPU-PRO from here

Run the following commands in the terminal

tar xvzf amdgpu-pro-16.40-348864.tar.xz

cd amdgpu-pro-16.40-348864

chmod +x amdgpu-pro-install

sudo ./amdgpu-pro-install

  • Your GPU has GCN 1.0 or newer whilst mine is pre-GCN. AMDGPU drivers only work for GCN 1.0 or newer and official support I think is only for 1.2 and newer. But your answer might help someone with a newer GPU than mine. – Carolus Dec 15 '17 at 8:55
0

I settled for the open-source drivers. I've gotten used to lower performance and I'm not interested of risking breaking everything. Also my performance drop might be due to an entirely different reason (hardware e.g.) which has yet to be explored.

Not the answer you're looking for? Browse other questions tagged or ask your own question.