0

Problem in sudo apt-get update

Hit archive.ubuntu.com vivid InRelease  
Hit archive.ubuntu.com vivid/universe amd64 Packages
Hit archive.ubuntu.com vivid/universe i386 Packages
Hit archive.ubuntu.com vivid/universe Translation-en
Ign ftp://gb.archive.ubuntu.com edgy InRelease  

Err gb.archive.ubuntu.com edgy Release.gpg
  Connection timeout
Ign gb.archive.ubuntu.com edgy Release
100% [Logging in]

It is stuck at logging in 100%.

still there is some problem in edgy release

Ign http://old-releases.ubuntu.com vivid InRelease
Ign http://old-releases.ubuntu.com vivid Release.gpg
Ign old-releases.ubuntu.com vivid Release
Err old-releases.ubuntu.com vivid/universe amd64 Packages
  404  Not Found
Err //old-releases.ubuntu.com vivid/universe i386 Packages
  404  Not Found
Ign ://old-releases.ubuntu.com vivid/universe Translation-en_IN
Ign ://old-releases.ubuntu.com vivid/universe Translation-en
Ign old-releases.ubuntu.com edgy InRelease
Err old-releases.ubuntu.com edgy Release.gpg
  Connection timeout
Ign old-releases.ubuntu.com edgy Release
24% [Logging in]
  • 1
    Are you sure to be running 14.04? Vivid is 15.04, which is EOL. – Melebius Sep 14 '16 at 8:07
  • Have you been editing your sources.list files manually in the past? It features sources from several different Ubuntu versions which shouldn't be the case. Edgy is 6.10 - Vivid is 15.04 and Trusty would be 14.04 - which isn't shown at all in the output. – dufte Sep 14 '16 at 8:13
  • yes it is 15.04 – Priya Sharma Sep 14 '16 at 8:45
  • 1
  • Why the heck do you have "edgy" stuff there? Edgy Eft was Ubuntu 6.04, which is outdated for over 9 years now! – Byte Commander Sep 14 '16 at 16:53
2

Edit your /etc/apt/sources.list/ and comment out all of the lines that contain either vivid or edgy by inserting a # character at the beginning of each of the lines. These lines don't make any sense, since edgy (6.10) and vivid (15.04) can't match with your version of Ubuntu, which is trusty (14.04).

  1. From the terminal run the following command to edit /etc/apt/sources.list/ with nano text editor:

    sudo nano /etc/apt/sources.list  
    

    The instructions for using nano editor are always found at the bottom of every page. The only two nano keyboard shortcuts that you need to know are for WriteOut and Exit. Press the keyboard combination Ctrl+O and after that press Enter to save the file being edited. Press the keyboard combination Ctrl+X to exit nano.

  2. Update your software sources.

    sudo apt-get update  
    

Your edited question shows that your release has changed from Ubuntu 14.04 to Ubuntu 15.04 which is an end of life release. If this is the case, your best option is now a clean install of the latest version of Ubuntu, Ubuntu 16.04. I would also recommend not enabling any Ubuntu 6.10 (edgy) software sources this time.

1

its seems your error is a Connection timeout

how ever , if you are using an unsupported version of ubuntu , i advice you

to edit your repo source list and do some minar edits and change your deb mirrors to old-files

  1. sudo cp /etc/apt/source.list /etc/apt/source.bkup

this is a backup , in case something went wrong

  1. sudo gedit /etc/apt/sources.list

find and change archive.ubuntu.com to old-releases.ubuntu.com

  1. sudo apt-get update clean

  2. sudo apt-get update --fix-missing

hopes this help .

  • sorry , am a beginner @ askubuntu stack exchange, dont know the rules of writing , and excuse me for not being English ..... – Ahmed Al-attar Sep 14 '16 at 10:29
  • Much nicer and easier on the eyes :) – Mark Kirby Sep 14 '16 at 10:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.