I have problem with my Sony Vaio Z VPCZ1. It has physical selector of GPUs which Linux kernel does not detect.

So after GRUB I see black display (I tried different distributions of Ubuntu and other Linux OS). I read in Ubuntu 10.10 was solve same problem with hybrid graphics but not in my case

I found solutions (not easy at do) for oldest models.

PS. for more information I found different webs: https://docs.google.com/document/edit?id=1DxDty2YGNJwq_I8zmVZxDMMXBP6g4HjaDjLfVfTs034&hl=en&pli=1

Update (2011.04.30): I tried update to Ubuntu 11.04 on my VPCZ11C5E and all work (without any patch) fine less Intel GPU (only works Nvidia).

up vote 5 down vote accepted

Finally I found solution in this web: http://www.voip-x.co.uk/files/adam/ :D

Thanks to "gokulvarma" -> with nomodeset I enter to console mode (tty). And I installed:

  • linux-image-2.6.36-0-vaioz_2.6.36-0.1_amd64.deb
  • linux-headers-2.6.36-0_2.6.36-0.1_all.deb
  • linux-headers-2.6.36-0-vaioz_2.6.36-0.1_amd64.deb

Thanks to Adam and Sony Vaio Z group, in launchpad, for this kernel! :))

So now work X mode and I can use both GPU. Nvidia graphic use Nouveau. If I install Nvidia driver (recommended or last) 3D mode is disable.

Both graphic work good with 3D mode but...

  • if I enter to Display setting or open some program (which use wine) display blind 1 or 2 times (only extern monitor).
  • sometimes Intel graphic not detect well extern monitor on the boot.

Other hardware work fine. Touch-pad work thanks to same patched kernel.

I hope this patch will be in new stable kernel.

PS. I installed Ubuntu 10.10 x64 with nomodeset. Here are steps for installation.

Update (2010.11.26): Kernel updated to 2.6.37-6. Thanks Adam! =))

Update (2011.04.30): I tried update to Ubuntu 11.04 on my VPCZ11C5E and all work (without any patch) fine less Intel GPU (only works Nvidia). Any way when I find so patch which improve Sony Vaio Z performance I going to post here.

  • Hi dpcat237, thanks for post your solution!!! Im not an expert using ubuntu and Im trying solve the same problem on my VAIO VPCZ1, I dont understand the correct way to do this, could you help me with this please? I have ubuntu 10.10 and I get the black screen after load grub, I can enter on tty console and nomodeset but I dont know how install the linux headers, image and others!!! Thanks for your assistence!!! – user8304 Jan 4 '11 at 0:25
  • Hi! I added steps about how I installed Ubuntu ;) – dpcat237 Jan 4 '11 at 15:17

Press e on getting the GRUB bootloader(if not getting grub, press and hold shift key to get grub).

Go to the line which says 'quiet and splash', delete these words and type in "nomodeset" (without quotes) Now press Ctrl + X to boot

Now login to your Ubuntu as usual. If you have a Nvidia graphics card, this may be the issue with it.

Now goto System->Administration->Hardware drivers, and select and activate the nvidia current driver if you have an nvidia card. The driver will be downloaded and activated automatically, and you will be prompted for a reboot.

  • Thanks. With this it enter to Ubuntu but only command-line =(( I tried change with "Alt+F2, etc." and all are without X mode ^^ I think is better boot with Intel GPU because it has less problems with compatibility, but I don't know how. – dpcat237 Oct 20 '10 at 6:44
  • in the command line enter sudo startx – Open Help Oct 23 '10 at 8:31

The sony-vaio-z-series Linux community is doing a great job at keeping up with the hardware nuisances. There are basically two z-series lines, the 2009 one and the 2010 one. Most of the linux-specific modules and tweaked kernels are now up-to-date to both. The Sony Vaio Z-series is the priciest of the kind but Linux people seem to be loving it. Asus U/UL series and Acer Timeline models are also doing well:


Yep, it worked for me too! Sony Vaio series Z 2010, I installed Kubuntu 10.10 with the nomodeset option to be able to see the installing graphical interface, then copied the Adams 2.6.37_amd64 linux image and headers, installed it with dpkg and it worked! Touchpad is working, screen brightness is working. However, I cannot figure out which graphic card is running. How can I know it?

  • Look to Dynamic graphics selector (DHGS)... Speed mode = Nvidia; Stamina mode = Intel. And about auto-mode I don't know if it work in Linux or only take one of two cards. – dpcat237 Dec 9 '10 at 7:01

I'm happy owner of VPCZ11. Some time ago I've patched my bios and set video card switching policy to manual. That way I got my nvidia card working with proprietary drivers and 'nomodeset' setting in grub. But brightness control wasn't working.

I got installed patched 2.6.37 kernel and almost succeed. What I've got is: both video cards working (intel and nvidia). Nvidia card is working with Nuoveau drivers (a bit slower than with original drivers). Brightness control works with both cards. But suspend doesn't work. Actually laptop suspends properly, but on keypress it performs fresh boot. Now I'm back to unpatched kernel on Ubuntu 10.10 Maverick. Suspend works fine, but Intel card is not usable and brightness control doesn't work too.

What I want is: have suspend working with intel card and patched kernel. I don't want performance, I'm writing code that should perform elsewhere and not on my laptop :) And I'm not a gamer person.

Thank you all for any suggestion/help :) Ubuntu forever! :) Banzai!


I've managed all my problems. Now I've got intel graphics card with 3D acceleration (read compiz) and suspend working. Read on:

So seems like 2.6.38 has fixed dkms for vaio laptops :) Congrats everyone! Waiting for Natty :)

  • You can ask about this in launchpad group. – dpcat237 Feb 16 '11 at 21:57

Apparently there is a lot to deal with for getting it on a VAIO Z (I prefered running through VBOX), but I found some additionnal information here, on page 6 there is apparently some bios patching recommended for avoiding the black screen issue. And the most recommended was installing the new nvidia driver.


  • Thanks, but there speaking about older models ^^ And I think with Linux is always possible found some solution :) – dpcat237 Oct 20 '10 at 5:44
  • so what is your exact model ? – dvhh Oct 20 '10 at 6:18

You can also try to use bumblebee. Have a look at this websites: https://launchpad.net/~hybrid-graphics-linux http://linux-hybrid-graphics.blogspot.com/

  • Thanks, but the problem is in button which change stat of hybrid graphics. It's only in this laptop. – dpcat237 Jun 2 '11 at 4:45

protected by Community Jun 18 '11 at 14:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.