2

I am making the transition from Windows to Ubuntu. My desktop has 32GB of physical memory installed and all detected by BIOS and previous versions of OS. Since I have moved to Ubuntu 16.04, it only recognizes 3.6GB. All OS tools report the same memory, free -h, top, dmesg etc.

I am running x86_64. Is there a config setting to access the full memory?

free -h:

free -h

top:

top

Please let me know if you need any log output or information. Thanks in advance.

Update

Output of dmesg | grep Memory

Root@AGsys:~# dmesg |grep Memory 
[ 0.000000] Memory: 3420004K/3667512K available (8394K kernel code, 1282K rwdata, 3944K rodata, 1480K init, 1292K bss, 247508K reserved, 0K cma-reserved)

Output of uname -a

root@AGsys:~# uname -a 
Linux AGsys 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
8
  • See askubuntu.com/questions/302586/… for a bunch of commands to see how much RAM your system has.
    – edwinksl
    Sep 14 '16 at 3:09
  • Thanks edwinksl. I've run sudo lshw -class memory. It shows the 2 DIMMs that I have but only shows 2GB in each instead of 16GB.
    – TechE Monk
    Sep 14 '16 at 3:32
  • 2
    This sign only looks like it has 32bit OS installed
    – Techjail
    Sep 14 '16 at 3:51
  • Hi Techjail, i am not currently in front of my PC, i will add the screenshot later but rest assured it is 64bit.
    – TechE Monk
    Sep 14 '16 at 4:04
  • Hi, following is the extract from #dmesg |grep Memory Root@AGsys:~# dmesg |grep Memory [ 0.000000] Memory: 3420004K/3667512K available (8394K kernel code, 1282K rwdata, 3944K rodata, 1480K init, 1292K bss, 247508K reserved, 0K cma-reserved) following is the extract of uname -a root@AGsys:~# uname -a Linux AGsys 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
    – TechE Monk
    Sep 14 '16 at 7:11
4

There are two likely causes for this:

  1. If you're running a 32-bit version of Ubuntu, it will only use a maximum of about 3.5 GB of your installed RAM, regardless how many and how big DIMMs you have. Since your system reports as 64-bit, if this is the case it may indicate additional problems; reinstalling clean is the most reliable way to fix this, though it may be due to leftover start command settings in GRUB.

  2. It's not unheard of to receive counterfeit parts. That is to say, it's possible you were sold 2 GB DIMMs as 32 GB DIMMs. Since I see from your last comment that you're running 64-bit Ubuntu, this seems the more likely possibility. If you remove one of the DIMMs and look at the part number stamped on one of the chips, you/we may be able to verify that the chip part is in fact a 32 Gb chip, or alternately that it's a 2 Gb part.

3
  • Hi Zeiss, thanks for your support. I have removed the DIMMs and verified that they are genuine 16GB DIMMs. As I mentioned earlier, I had windows running on this system before and I recognized the 32GB . I will try and reinstall Ubuntu 64bit again and see if that helps resolve the issue.
    – TechE Monk
    Sep 14 '16 at 12:36
  • The only other things I can think of at present is that you've somehow got a 32-bit kernel reporting as 64-bit, or something in your motherboard's RAM controller isn't supported by your Ubuntu installation. Both seem pretty unlikely.
    – Zeiss Ikon
    Sep 14 '16 at 13:04
  • The first one is a possibility as I upgraded from 14.04 and I hadnt used that for a while and I did not bother checking what version I was running. i am doing a clean install now. Will update shortly.
    – TechE Monk
    Sep 15 '16 at 2:05
0

UPDATE

It appears that the issue was with the 32bit kernel that I had before I upgraded to 64bit 16.04. I installed 16.04 after a clean install and I can see the correct memory now.

Thanks for your support.

Cheers!

3
  • 2
    Instead of writing an answer, I think you should accept @ZeissIkon's answer, which, as far as I can tell, essentially solved your problem.
    – edwinksl
    Sep 21 '16 at 2:23
  • 2
    And how did you figure out your kernel is 32 bit ? somehow i am not too certain this is all correct. Can you please tell us what dpkg --print-architecture ? Also, consider doing memory test from the boot menu ( you should see an option for that ) . It's not uncommon to have broken RAM due to static electricity when touching it Sep 21 '16 at 2:30
  • "32bit kernel that I had before I upgraded to 64bit" you can't upgrade from 32 to 64-bit.
    – Rinzwind
    Sep 21 '16 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.