0

I have a Lenovo Z50-70 (NVIDIA and Intel) RAM and swap 8 GB, with dual boot, Ubuntu GNOME 16.04/Windows 10 and every time I try to suspend it, it first suspends normally but then I can not resume successfully. It shows me the screen where I left off but it is completely frozen, and I cannot do anything else than reboot with the button.

With Windows 10 suspend works normally.

I have tried suspending from virtual console with no success and I have tried with Intel and NVIDIA (both drivers prop and open source) graphics with no success.

I want to be able to close my laptop and have it suspend normally and the continue working after resuming.

EDIT: I tried SuperMohit's solution and:

When I run nvidia-settings I get this:

ERROR: Error querying enabled displays on GPU 0 (Missing Extension).

ERROR: Error querying connected displays on GPU 0 (Missing Extension).

** (nvidia-settings:8554): WARNING **: PRIME: Failed to execute child process "/usr/bin/prime-supported" (No such file or directory) ** Message: PRIME: is it supported? no

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and descriptions.

And then the window opens, but I do not see any "PRIME Profiles" tab, only "Rules", and "Profile" tabs, with nothing in them.

0

Found the solution on another forum. The problem is with two GPU's, Intel & Nvidia. If Nvdia is the default GPU, suspend and hibernate will have issues.

Step1 : Run nvidia-settings on terminal.

Step2 : In "PRIME Profiles" tab, select the GPU as "Intel" instead of "NVIDIA".

Step3 : Save and restart your machine.

I tested this on 14.0.4 and it worked.

  • Thanks, I tried it and edited my question with what happened. – Leonel Sánchez Dec 7 '16 at 20:55
  • Are you using the proprietary graphic driver of Nvidia? If not then try using that and then run the command. – anandmt Dec 7 '16 at 22:28
  • I was not, but I changed it to the propietary one: version 340.98 from nvidia-340 and have the same message posted on the edit in the question. Any other suggestion is welcomed. Is there like another way to COMPLETLEY disable the Nvidia card so maybe it will only use the Intel one so there will be no problems? – Leonel Sánchez Dec 9 '16 at 5:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.