2

I'm new to linux and tried yesterday to install my first ubuntu as a dual boot with the already existing windows 10. However, I ran into some problems. After installing ubuntu windows automatically started, without giving me a dual boot option. The windows screen was messed up (showing 2 flattened windows screens on my screen) as if it was using the screen sizes from ubuntu in my windows installation. Then I tried starting ubuntu via a flash drive, using the 'try ubuntu' option, that worked, so I ran a boot-repair. Now ubuntu starts automatically, without giving me the option to start windows.

What I already tried:

  • Before I installed ubuntu I made sure secure boot and fast boot were disabled
  • I made sure that all boot-options in bios were set to legacy mode before installing ubuntu since my windows seems to be in legacy mode, see below (this after trying to install it without doing so previously which also gave similar problems)
  • I made sure CSM was enabled in my bios
  • I tried looking for ways to change the boot order, but only one bootable device is listed
  • I tried installing ubuntu as UEFI, that made my pc boot nothing at all, just gave an error (though this might have had something to do with me installing it as Ext2?) and I had to reinstall windows and start over

What I know:

  • Windows appears (and already appeared beforehand) to run in legacy mode. I assume this because the ubuntu installer said that I had a system in legacy mode (and therefore I installed ubuntu in legacy mode as well). Also when I go into BIOS it talks about bios options and such, I imagine if I was using (u)efi it wouldn't talk about bios. EDIT: I have to correct this a little, the title of my BIOS is 'UEFI dual BIOS'
  • My windows version is windows 10 education 32/64 bit
  • I can access the windows 10 drive from ubuntu and see the files in the windows partition
  • file system for ubuntu partition is Ext4

I spent a day and a half almost fulltime trying to fix this. I googled as much as I could and tried all the advice I found that reasonably made sense and I'm not one step closer to fixing the problem (except that I know which solutions don't work I guess :P). I could use your help! If any more information is needed, please let me know.

Edit: corrected some information about my bios type, see the edit in the what I know section above

Edit2: the boot repair pastebin as requested: http://paste2.org/V8DcV65J

Edit3: Tried something new, since I was at some point able to boot into windows I thought my problem might be similar to that of this guy: Can boot to Ubuntu, or Windows, but not both Turns out that was wrong :P To turn on secure boot I had to disable CSM, which made it unable for me to start either windows or ubuntu I just loaded straight into bios on startup (regardless of whether I enabled secureboot or not). Also the solution that worked for him is entirely unable for me (I don't see the checkbox)

Also worth noting, I do load into grub on startup (when CSM is enabled, of course) it just only allows me to choose between ubuntu, advanced options for ubuntu and system setup. I also tried pressing f12 on startup (loads you into boot-options) but there I have the problem where it only gives me my harddrive, so one option, to load into, and not the two partitions.

edit4: it may be nothing, but in grub, when I choose the system setup option it says: error: can't find command fwsetup.

0

Maybe it's something with GRUB. Try to hold "shift" key while starting computer. Eventually hold space or esc key. In those trheads there are other ways to enable GRUB menu at start Link1, Link2

Have you tried saving secure boot keys to usb stick and deleting platform keys in your UEFI? Tutorial for ASUS motherboards

UEFI based stuff have a lot of default options that causes errors while installing other OS. Have you tried to install bootloader on other partition? In my case - 1 SSD with windows bootloader and another drive with Ubuntu bootloader didnt work. only windows showed, and was no GRUB. But when I installed bootloader on the same drive as windows, it worked.

  • Hey, thanks a lot for your help! Grub is not the problem, I get grub, but I only have the options to load into ubuntu, advanced options for ubuntu or system setup. I don't think secure boot is the problem, I tried enabling it that just made nothing work (see the edit in my post for more details). So I'd rather not go deleting stuff if that isn't necessary. If you still think it might solve my problem let me know and I'll try it. I only have one ssd to begin with, no other drives for me to put it on. – Hasse Iona Sep 14 '16 at 11:01
  • If you are still in Legacy mode, try change it to uefi and legacy. Windows should work in UEFI mode, but Linux on legacy, enabling both would give a chance. Platform keys are used to boot only that software what have microsoft permission. But if you have GRUB and working linux, there is no need to delete this – Piteight Sep 14 '16 at 11:40
  • Are you sure windows works in uefi mode? When I disable CSM support nothing starts, not even windows. Either way I don't think I have the option to enable both. In my BIOS it gives me the following options: CSM support [Enabled/Disabled] Storage Boot Option Control [Legacy only/UEFI only/Disabled] other PCI device ROM priotity [Legacy only/UEFI only/Disabled] – Hasse Iona Sep 14 '16 at 11:52
  • There also could be a problem with windows boot(Your log says, that it detected only ubuntu and unknown OS), so you can try repairing windows boot from windows DVD repair option. – Piteight Sep 14 '16 at 11:52
  • It said 'startup repair couldn't repair your pc' and gave me a log file: paste2.org/W5hJsMeX something strange I noticed is that it said windows was on the E drive, it might be nothing, but I named the partition I installed Ubuntu on E (the log file was however where it was supposed to be, in the windows partition, that I can access through my ubuntu) – Hasse Iona Sep 14 '16 at 12:10
0

A friend found the solution for me! Turns out the solution was to update grub:

sudo grub-mkconfig -o /boot/grub/grub.cfg

as can be found in this post: Dual booting doesn't load Windows anymore

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.