13

I have access to a cluster and wanted to use the simplest example to ssh into it with X11 forwarding and see if it works. Currently, I simply log into the cluster:

$ ssh -Y user@cluster

and the only program that I know in the cluster that has some display (like a gui) is matlab, so I just run it:

$ matlab

in the past that works but I wanted to know of the simplest command to display something in my screen to see if its working or not. Currently, running matlab opens the command interface but it doesn't display an error or anything else.

Does someone know what is an alternative command to see if anything is working? A single command that is inherit with Ubuntu and doesn't require me to install anything beyond X11 is the idea. Something like:

$ display_a_box_with_text HELLOWORLD

I am not sure if its just me but it seems ridiculous that the only way to check if X11 is working is by running MATLAB. There must be a better way to check this.

  • 1
    Run the command: xeyes. – L. D. James Sep 13 '16 at 18:14
  • @L.D.James that command wasn't found. For the record, matlab works now (for some reason -Y didn't work in the system I was using, though it seems ridiculous to me that the only way to check if it even works if by running matlab. Might work for me but not for general user) – Pinocchio Sep 13 '16 at 18:23
  • 3
    xeyes, xclock, oclock, xcalc, xgc, xedit, xlogo, xman are pretty standard X11 applications. They are included in the packet x11-apps. – nobody Sep 13 '16 at 18:39
  • @Pinocchio Have you tried something from my answer? – Thiago Rider Augusto Sep 14 '16 at 14:31
  • @ThiagoRiderAugusto yes I tried the -v and -Y and xterm. That opened a window through XQuartz, so I assume that worked. Thanks! – Pinocchio Sep 16 '16 at 17:31
14

Instead of the ssh command you issued, try:

$ ssh -v -Y user@cluster

Add another argument -v enable the debugging mode for ssh command. Search for a line containing Requesting X11 forwarding, like in:

$ ssh -v -Y user@cluster
[...]
debug1: Requesting X11 forwarding with authentication spoofing.
[...]

After logging in, you can try the following commands for opening a X window: xterm, xclock, xcalc, xedit, etc These were already mentioned in comments.

You asked for a dialog box with a custom text, so you should try xmessage:

$ xmessage -center hello!
|improve this answer|||||
  • 2
    The only command the cluster I am using had was xterm. I can't install any of the other commands because I am not sudo, but xterm worked just fine! Thx. – Pinocchio Sep 16 '16 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.