I can successfully connect a Mi BlueTooth speaker to Ubuntu, but I cannot play sound through it, because it is not listed in my sound output list.

Bluetooth module for PulseAudio sound server

Is present on my system, however running sudo pactl load-module module-bluetooth-discover returns:

Failure: Module initialization failed. 

How can I solve this issue? `

  • what if you do not use sudo for loading a module? – Takkat Sep 13 '16 at 13:42
  • same result @Takkat – Subhadip Roy Sep 13 '16 at 13:43
up vote 15 down vote accepted

One way to solve the problem is to:

  1. unpair the device
  2. run the following command on terminal: sudo pkill pulseaudio
  3. and then pair again the speaker via bluetooth.

The speaker is now displayed on the output audio list, which needs to selected for obtaining output sound.

Remember to, under Sound Settings, change Mode to High Fidelity Playback (A2DP Sink).

This is what is working for me for Bose QuietComfort 35 on Ubuntu 16.04. pauvcontrol didn't do it for me, and neither did the numerous settings changes and module loadings recommended elsewhere. So give this a try:

  1. Install blueman sudo apt install blueman
  2. Delete the paired device in the bluetooth settings.
  3. Run these commands in terminal: bash sudo pkill pulseaudio sudo /etc/init.d/bluetooth restart
  4. Turn off headphones.
  5. Turn on headphones, and press green/go until headphones notification voice says "Ready to pair."
  6. Launch blueman, and from the upper right menu, right-click the icon to bring up the blueman menu. Select Setup new device.
  7. Pair the device, and when you are given an option, not headphones, not handsfree. Use the Audio sink option.
  8. Then when you look into the audio settings panel, the device should be displayed.
  • 2
    Thanks, that worked. Kinda sucks that it is required so often. No permanent solution. – umpirsky Nov 4 '17 at 9:24
  • This 'kind of' works for me, my QC35 appears in the sound output again. But it connects in HSP/HFP mode (mono). I cannot switch it to A2DP stereo mode. – Jesse Busman 2 days ago
  • and.. after getting frustruted and pkilling pulseaudio 1000 times in a bash loop, somehow it started working in A2DP mode again. Bluetooth is an absolute nightmare on ubuntu :/ – Jesse Busman 2 days ago

I had to use Lou Gro's blueman solution every time I rebooted. This fixed it for me:

https://wiki.archlinux.org/index.php/Bluetooth_headset#Gnome_with_GDM

Follow the instructions under "Gnome with GDM" (use gdm3 in the paths instead of gdm for Gnome 3)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.