I've just installed Ubuntu desktop 16.04 (x64) on ASUS k501U. Sometimes (not always), my mouse pointer disappears after login. I tried some solutions like Ctrl+Alt+F1 and Ctrl+Alt+F7 but they did not fix the problem. After I restart, mouse usually appears again.

It's quite an annoying issue, is there a way to fix?


12 Answers 12


have the same problem after upgrading to 16.04. Often the mouse pointer will disappear. I found a way to get round this by restarting lightdm:

sudo service lightdm restart

but it's not a fix solution, since each time I have to type the command again.

So I changed lightdm to gdm:

sudo apt-get install gdm
  • sudo service lightdm restart fixed my issue with Ubuntu on VBox on MacOS. Tnx buddy.
    – CppChase
    Jan 31, 2018 at 8:26
  • Restarting your DE may not always be an option. The solution posted by @T04435 should be the accepted answer.
    – Juanpi
    Jun 15, 2019 at 12:35

This fixed for me on Ubuntu 19.04:

gsettings set org.gnome.settings-daemon.plugins.cursor active false
  • Works for me on Ubuntu 16.04 when also set “org.gnome.settings-daemon.plugins.mouse active” to false: gsettings set org.gnome.settings-daemon.plugins.cursor active false gsettings set org.gnome.settings-daemon.plugins.mouse active false
    – NieFan
    Nov 11, 2019 at 9:01
  • 1
    This worked for me, but I had to reboot first.
    – Phil_T
    Feb 19, 2020 at 19:03

On my laptop running Ubuntu 16.04, the mouse pointer disappeared frequently.

My problem was: The mouse pointer seemed to disappear when I moved to the right side of the screen. It then appeared after say 3 to 5 seconds after moving the mouse up, down, left, right. This was quite annoying when doing work on the computer.

The solution was:

Click Dash (upper left corner) and type "system settings". Click "System Settings", then All Settings > Displays If its as of my case, you will see a box call Unknown Display to the left of Built in Display in a big box with grey background

Click on unknown display and de-activate it by turning off the button just below the grey box.

I found the answer here (Thanks to Justin Samuel!).

  • Works like a charm on a fresh install of 16.04 LTS on a MacBook Pro (A1286).
    – Duc
    Apr 17, 2017 at 17:33

In my case none of the above works. The mouse disappears because of enabling coolbits on a .deb installed Nvidia graphics drivers.

The issue seems to work on a clean Lubuntu/ubuntu install installing the drivers from the .run file instead.

  • Interestingly, this problem started happening to me as well right after enabling coolbits for NVIDIA GPUs.
    – merlinND
    Jun 23, 2020 at 8:10

Just shake your mouse, it will appear again. You can repeat this process each time your mouse disappears. This fix will the problem!


In my case one of the above worked fine for a while (I will try to look up where I left the fix, it's been a while since I applied it), but nowadays things are a bit hectic and the cursor disappears say in 20% of the cases.

A sign out/re-login attempt sometimes helps in these cases. (Obviously not meant to be a fix/answer, just a suggestion for cases when in need of a quick temporary workaround.)


My mouse was disappearing on the login screen on my laptop and after trying all the answers here (and elsewhere) I plugged in a USB mouse and the mouse showed up again and worked when using the USB mouse (but the trackpad still wouldn't work). To get the trackpad working again I had to restart WHILE the USB mouse was plugged in. Now I'm back to normal.

No idea why this worked... I'm on Ubuntu 16.04, and all of the terminal commands I ran showed the trackpad as expected.


Mouse cursor disappear should be some bugs of the mouse support service in Ubuntu.
I installed mouse service "gpm" in my Ubuntu server 20.04 on VirtualBox. Mouse cursor disappears frequently in Ubuntu terminal when I switch between VirtualBox and windows 10.
Other than rebooting VM, my lightweight solution is to stop the mouse support service "gpm" and restart it again as below:

sudo gpm -k                                  //stop gpm
sudo gpm -m /dev/input/mice -t exps2         //restart gpm

There should be similar mouse support service for Ubuntu Desktop which can be stopped and restarted as a lightweight solution.


I just pressed Ctrl+Alt+Shift+T and the pointer re-appeared. I'll have to try it again before I know if its just a coincidence as it re-appears by itself sometimes.


I just had the same problem (Apr. 2022).

I my case it was because I had a second monitor connected. Even with the second monitor being turned off, the mouse pointer moved over the left edge of the active monitor to go to the other monitor.

Unplugging the cable solved the problem.

This also caused certain programs to be invisible when opening.


Edge case for disappearing mouse with two GPUs and two monitors.

I tried to create an extra "Screen" in nvidia-settings so each GPU would drive a separate monitor (sounds like it should work, right?).

A third "Prime Display" showed up and the problems started. Even disabling this third display did not fix it.

Went into xorg.conf and just deleted the extra "Screen 1" section at the bottom, leaving only the "Screen 0" (as it was before I started messing with this).

Everything is fine now.


On VMWare, it was a Unity mode that caused my problem. Under the player menu is a Unity option. I clicked the Unity button and it restored by cursor.

  • 1
    We can understand nothing, Try to be more clear, simple and precise. Nov 6, 2020 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .