I've been using my laptop with two partitions, Windows 8 and Ubuntu 16.04 to study. However, in my house, the wifi connection in Ubuntu does not work as well as the Windows. If im not right next to the router it loads at a turtle pace, while when im using windows 8 it has no problem to run anywhere.

I've followed the steps of this guide https://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/ But it has not worked

Is there a fix to it? What info can i show to speed up the process?

lspci -knn | grep Net -A2:

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723] Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c] Kernel driver in use: rtl8723be Kernel modules: rtl8723be

  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command.
    – Pilot6
    Sep 12, 2016 at 15:53

1 Answer 1


In the newer versions of the iwlwifi driver, the "11n_disable" parameter has more than two values - 0 or 1. I recommend you try value '8', which enables Tx aggregation, enabling the interface to push larger packets per second, thus possibly gaining better speeds.

If you have added the "11n_disable=1" parameter to the '/etc/modprobe.d/iwlwifi.conf' file, this command will change the value '1' to '8' - Code:

sudo sed -i 's/11n_disable=1/11n_disable=8/' /etc/modprobe.d/iwlwifi.conf

If you haven't yet added that option, you can add it now with - Code:

echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

Of course try any one of the above as applicable, not both.

  • 1
    Why do you think OP has an Intel wireless adapter?
    – Pilot6
    Sep 12, 2016 at 15:54
  • Its working better now, Thanks! Its still not as full speed as it should, but at least i can actually navigate Sep 12, 2016 at 16:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .