0

When i try to run:

primusrun glxgears

I get the following error:

primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

I tried to add this:

Section "Screen"
Identifier "Default Screen"
Device "DiscreteNvidia"
EndSection

to xorg.conf.nvidia as it is explain here Kubuntu 16.04 + Bumblebee Failed to load module "mouse" (module does not exist, 0) but the only thing i get when i change the xorg.conf.nvidia to that and restart bumblebeed.service is:

primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) Problem parsing the config file

Neither primusrun or optirun work, they give the same error. Thanks for the help

1

This might not be a solution for you, but I'll post anyway.

Is there a reason for you to use bumblebee besides not having to log out and log in? If the reason is energy consumption, which is high when not using bbswitch, I've coded a version of prime-indicator with power management capabilities, which can be found here: https://github.com/andrebrait/prime-indicator.

I've tested it quite a lot since yesterday and I've had no problems with it, with the benefit of having less bugs and better power consumption than with bumblebee. The only caveat is having to log out and log in again in order to switch the active GPU.

  • I should note that, by default, if using the the NVIDIA drivers up to version 361, Ubuntu itself turns the NVIDIA card off by default. – andrebrait Sep 16 '16 at 4:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.