While using 10.04 and the previous versions I used to put Ctrl+F6 to zoom in and subsequently Ctrl+F7 to zoom out. Now (using 11.10, Unity) I can't even find the options to zoom in and zoom out in the "keyboard shortcuts". I tried "the Magnifier" in the Compiz but really can't understand what is going on right there. There is simple question I would like to ask:

What to do so as to be able to zoom in with Ctrl+F6 and zoom out with Ctrl+F7?

  • Accidentally I pressed Super+D and magnifier feature start in my ubuntu 13.04 . For zoom in only. I don't know for zoom out.
    – Akatsuki
    Apr 17, 2014 at 7:12

7 Answers 7


Gnome Shell / Ubuntu 17.10+ : Magnifier

With GNOME Shell (instead of Compiz) as Window Manager (wmctrl -m):

  • Super+Alt+8: Toggle zoom enabled/disabled
  • Super+Alt++/-: To increase/decrease zoom.
    On some non-English keyboard layouts + won't work, try 0 instead.

Surprisingly, numpad +/- won't work.

You can change the shortcuts on Settings > Devices > Keyboard and zoom options on Settings > Universal access settings > Zoom:




  • Screenshot of an area (Ctrl + Shift + PrntScrn seems to be broken when zoom is enabled. It captures a region with an offset.
  • Does not start to zoom where the pointer is located, and in general you might find it very buggy.
  • AFAIK there is no way (as in XFCE) to smoothly zoom in/out with mousewheel/scroll. Couldn't find even a GNOME extension.

See also

  • Magnify a screen area

  • Orca: Orca is a free, open source, flexible, and extensible screen reader that provides access to the graphical desktop via speech and refreshable braille.

  • On 20.04 with gnome-shell 3.36.9 it seems to be a bug that slow down everything when zoom is enabled. journalctl -p warning -xef return

    gnome-shell[3302]: clutter_actor_allocate: assertion '!isnan (real_allocation.x1) && !isnan (real_allocation.x2) && !isnan (real_allocation.y1) && !isnan (real_allocation.y2)' failed
    gnome-shell[3302]: clutter_actor_allocate: assertion '!isnan (real_allocation.x1) && !isnan (real_allocation.x2) && !isnan (real_allocation.y1) && !isnan (real_allocation.y2)' failed
    gnome-shell[3302]: Source ID 6859556 was not found when attempting to remove it

Unity (until Ubuntu 17.04)

Unity Tweak Tool

Other than the Compizconfig Settings Manager, a new configuration tool is now available called Unity Tweak Tool.

Open Dash (by tapping on Super) and type "Unity Tweak Tool".

Unity Tweak Tool in Dash

If it is not available, you can install it from the command line with the following command:

sudo apt-get install unity-tweak-tool

Open the application, and from the icons choose General under the Window Manager section.

Unity Tweak Tool Main Window

Once you click General, enable the "Desktop magnification" option at the top. And you can change the default keyboard shortcuts of the Zoom In, and Zoom Out functionalities.

As seen in the next screen-shot, I have the Zoom In set to Ctrl+Super+Z and the Zoom Out set to Ctrl+Shift+Super+Z

Personally, I prefer including the Super key to all system wide shortcuts so it won't interfere with a certain application's shortcut.

Unity Tweak Tool Zoom Functionality

  • Weirdly, Unity Tweak doesn't work for me. I can enable "Desktop Magnification" and set the shortcut, but the shortcut doesn't work. After closing and reopening Unity Tweak, the option is disabled again. Apr 7, 2017 at 7:00
  • Okay, so after finally finding this thread I just restarted my computer, and it works now. Apr 7, 2017 at 7:28

Unity (until Ubuntu 17.04)

CompizConfig Settings Manager

  1. Open CompizConfig Settings Manager.

  2. Go to Accessibility / Enhanced Zoom Desktop.

  3. Click on the "Disabled" titled Button of Zoom in, click on enable, grab key combination and press ctrl+f7. Do the same for Zoom out, and you are set.


  • so the enhanced zoom is disabled by default in Oneiric and PRecise? And does it work fine when enabled?
    – MestreLion
    May 18, 2012 at 19:47
  • Every time I enable it in Compiz, and close out, it is immediately disabled again. In fact, if I click to enable it, and wait a few seconds, it automatically un-checks without explanation. Apr 7, 2017 at 7:08
  • There is (at least) this annoying bug when using mirror displays. Apr 3, 2018 at 23:14
  • This comment is rather off-topic maybe, but I want to thank you because your answer has helped me to solve my problem. No, not directly, but indirectly, because it inspired me to go deeper in the Zoom Options. Well, in my case, cat walkef over the keyboard, and all the screen was super-zoomed because of that. And it was a persistent problem. Inspired by your answer, I checked the Universal Acccess and saw that the Zoom Options was "on". I set it "off" and everything went back to normal. Damn "furry programmer"! I told my mother not to let the cats on the office! 😓 Oct 25, 2018 at 12:55

In Xubuntu VMs you could also do: FN + ALT + Mouse Zoom

  • 3
    Bro, I know this is old, but I have this page bookmarked because of this. I finally just decided to comment and say thanks for being here, when my brain goes retarded lol.
    – DPS
    Sep 19, 2019 at 19:23

Ctl + Shift + - to reduce
Ctl + Shift + + to increase

I found you also need the + from numerical keypad not the one next to the backspace button.

  • that is because + symbol is usually mapped to be produced when the key with += symbol is pressed along with the Shift key ;-) Oct 13, 2021 at 1:10

I found that ctrl and the + sign from the num pad works for zoom, and the same thing but the minus sign from the num pad zooms out. I am on ubuntu 18.04, hope this helps you

  • This only apply to web browsers. Apr 3, 2019 at 5:16

On almost all web browsers it is worked for me:

Ctrl + + will Zoom In.

Ctrl + - will Zoom Out.

  • 3
    C-+ and C-- are simply passed through to the client window, and many applications, e.g., Google Chrome, interpret it. Hence it "works" in that that one window zooms. But they don't affect the screen-level zoom, where the pixels get magnified (hence the screen appears fuzzy), and moving the mouse pushed around the image.
    – Quigi
    May 26, 2016 at 14:30
  • 1
    @Quigi is right -- in particular, I'm looking for a way to zoom in for an application that didn't implement zoom. I think any well-designed application should interpret ctrl+ and ctrl- as zoom, but not all of them dod. Apr 7, 2017 at 6:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .