0

I've been using various versions of Ubuntu as diskless workstations (PXE boot) for a while (8.10 - 15.04), I'm actually a co-author of this page.

Now I experience weird issue with Ubuntu 16.04. It hangs the system completely when I switch to virtual consoles (CTRL-ALT-Fx). There's no chance to SSH to it. It happens both when I upgrade from 15.04 to 16.04 or when I use clean installation.

  • it does NOT happen on normal 'disk' installations where system is running from a hard disk. I can freely switch between GUI and virtual consoles.

  • it does happen after the system boots and login manager is shown. I can sign-in, everything looks OK in X except for switching to virtual console or shutting down the system (it closes the GUI, switches to the console and freezes)

Hardware:

  • Intel Core i5-4590
  • integrated graphics
  • 8GB RAM
  • no disk
  • Is it possible that it's related to the fact that I'm booting the non-signed kernel when in diskless (netboot) mode? It worked fine when booted from harddisk, but perhaps it was using the signed version of the kernel. – januszm Sep 14 '16 at 11:34
0

It looks like it was all about setting kernel parameters. I tried upgrading the kernel to 4.7.4 but this didn't help.

It works if I set the following parameters:

video=uvsesafb:mode_option=1680x1050-24,mtrr=3,scroll=ywrap,noedid

I'd prefer to not hardcode the screen resolution though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.