1

So I have the oddest issue which I can't figure out. Out of the blue, my computer is refusing to download any torrents. I know it isn't an ISP issue because all other devices are.

Also, when I play around with the port numbers or download a new torrent client, it allows me to download one torrent. The next torrent that I enter in after that gets 0 KB speed. I've tried Deluge, Utorrent, Transmission. The same result.

I'm completely baffled and I have no idea how to troubleshoot this any other way. I've tried manually opening the ports, lowering my firewall. No luck.

I'm using Ubuntu 16.04. The problem has magically appeared three-four days ago.

protected by Community Sep 15 '16 at 9:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.