1

Recently my laptop keyboard stopped working. I'm now using Logitech wireless keyboard and configured it with a receiver via Solaar.

My laptop Keyboard was working before, I actually have no idea why it stopped working.

Kindly give some suggestion or solutions regarding this problem.

EDIT: Wireless Logitech keyboard and mouse are working just fine, but my laptop keyboard is not responding. When I type on it, keys got lighten up so it recognize the action but it has 0 effect in GUI.

EDIT2: I tried to reinstall my system now, wirelss keyboard is working from very beginning while notebook keyboard is not working - Solaar is not installed

EDIT3: Grub file:

linux   /boot/vmlinuz-4.2.0-42-generic.efi.signed root=UUID=9d551829-77be-4690-8097-0bd9b6adce29  acpi=force acpi_osi=! ro  quiet splash $vt_handoff
4
  • Does it work in other computers? – user589808 Sep 11 '16 at 22:25
  • Normal wireless keyboard is working just fine, i'm speaking about laptop keyboard only – Michał Żywiecki Sep 11 '16 at 22:31
  • Does the laptop keyboard work in BIOS? – WinEunuuchs2Unix Sep 11 '16 at 23:26
  • Yes it is working . I just tried to reinstall my system. Wireless mouse and keyboard is working from very beginning even without solaar while default laptop keyboard is not working. – Michał Żywiecki Sep 11 '16 at 23:43
1

I faced the same problem with my ASUS GL552VW. Fixed with a simple kernel parameter change.

1) Install Grub Customizer

sudo add-apt-repository ppa:danielrichter2007/grub-customizer -y
sudo apt update
sudo apt install grub-customizer

2) Open Grub Customizer and Edit the grub entry (with the Pencil Icon) Grub Customizer

3) Now make the desired changes. In this case,Edit Menu

you need to add a parameter on the second last line that starts with linux /boot/vmlinuz-xxx.... add acpi_osi=! before ro quiet splash $vt_handoff

You might also want to use acpi=force

Click OK and Save. Now hard reset your laptop. It should be fixed from the next boot.

I'm using these parameters to boot and this fixes all the function keys operations, keyboard backlight, graphics and the shutdown problem.

linux /boot/vmlinuz-4.4.0-36-generic.efi.signed root=UUID=7e43add9-fbc2-4946-a640-0b269d17c117 i915.modeset=0 nouveau.modeset=1 nvidia.modeset=1 idle=nomwait acpi=force acpi_osi=! acpi_backlight=native ro quiet splash $vt_handoff

7
  • 1
    please explain how to set a boot parameter, OP may not know this – Zanna Sep 12 '16 at 10:24
  • edited. Link added elementaryos.stackexchange.com/a/7662/6199 – skb50bd Sep 12 '16 at 11:39
  • the link may break so please include steps here – Zanna Sep 12 '16 at 11:41
  • OK. added everything – skb50bd Sep 12 '16 at 11:57
  • wow... I would just edit /etc/default/grub but thanks for improving your answer :) – Zanna Sep 12 '16 at 12:06
0

Motherboard was damaged. After replacement everything is working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.