I shall just give a bit of background information. I updated a broken Ubuntu installation to Oneiric from the live CD a while ago, and everything appeared to be working fine. Because I don't use the affected PC (it's mainly for my family), I booted it back into Windows after trying out 11.10. However, during the upgrade, I checked the "install bootloader" option for some reason, even though GRUB was already installed. Before the upgrade, I had configured the system startup to load the Windows bootloader first, which would display the options "Microsoft Windows" and "Ubuntu". Choosing "Ubuntu" would obviously load GRUB, which would show all of the installed Linux distributions as well as an option to reload the Windows loader, located at the bottom of the list. However, after I upgraded, GRUB was default due to the reinstall. This wasn't a major problem, as I could always set the Windows BL as default, or just set GRUB to highlight the Windows loader option by default.

Anyway, to the real issue: at boot, the system drops to a GRUB rescue TTY, giving the error "unknown filesystem". Because I saw a shell that I'm not really familiar with, I typed some common Unix commands to see what kind of environment I was in. My first command was ls, and it worked; it showed a list of filesystems. It output: (hd0) (hd0,msdos3) (hd0,msdos2) (hd0,msdos1).

I'm not sure what to do from here. I'm assuming I should boot into a live environment and do some common disk operations. Should I run fsck? If all is well or repairs succeed, should I update the GRUB configuration? How so? If all is not well, what then?

Thanks in advance.

  • 1
    maybe this answer is helpful for you?
    – tohuwawohu
    Nov 24, 2011 at 15:43
  • @tohuwawohu That worked perfectly... Windows is doing a disk check, which I'm pretty sure will exit properly. I'll have to give the developer of that some acknowledgement. Thanks! Nov 24, 2011 at 16:05
  • @tohuwawohu Please post your comment as an answer. Op, please accept the answer when it's posted. Thanks! :)
    – SirCharlo
    May 17, 2012 at 16:01

1 Answer 1


Maybe the boot repair tool will help (see also this and this answer). You can install it inside a live system using:

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo apt-get update && sudo apt-get install -y boot-repair && boot-repair

Here's some information how to proceed in grub rescue mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.