7

I installed KVM on ubuntu 16.04 and when I run virt manager it shows this message:

Warning: KVM is not available. This may mean the KVM package is not installed, or the KVM kernel modules are not loaded. Your virtual machines may perform poorly

enter image description here

4

You either haven't installed qemu-kvm or you don't have virtualization enabled from BIOS.

Run this to make sure that you have KVM modules installed:

sudo apt-get install kvm qemu

And run this to make sure you have virtualization enabled from BIOS (If you don't then enable that):

grep vmx /proc/cpuinfo

4
  • as you say i did it, and then i open virt-manager now it show me ERROR: No Active Connection to install on
    – harsh
    Sep 12 '16 at 7:43
  • @harsh, what hardware do you have brand/model? I have seen similar case when VT is enabled but virtualbox couldn't detect it. (an HP Elite Pro) We fixed that by upgrading EFI/BIOS firmware.
    – user.dz
    Nov 17 '16 at 12:02
  • 2
    Enabling virtual in the bios was correct. There were Advanced settings in CPU and North Bridge for virtualization. On Ubuntu 18.04, kvm is no longer a package. apt install qemu-kvm worked. On AMD Rizen 1700, the grep for vmx did not work. In /proc/cpuinfo, vmx is for Intel, smx is for AMD. The grep command should be: grep "vmx\|svm" /proc/cpuinfo. Jul 4 '18 at 23:47
  • 1
    I get Package kvm is not available, but is referred to by another package.
    – Navin
    Jun 5 '19 at 4:29
0

For the users of Ubuntu 20.04 just run:

apt install qemu-kvm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.