5

Since yesterday afternoon I'm getting some GPG key expired errors from the official repositories (I checked my sources.list and the only sources are the official ones).

The URL I'm getting the error from: http://apt.insynchq.com/ubuntu/dists/xenial/InRelease

And the KEYEXPIRED errors:

KEYEXPIRED 1473479811  
KEYEXPIRED 1473479811  
KEYEXPIRED 1473479811  
KEYEXPIRED 1473479811  
KEYEXPIRED 1473479811  
KEYEXPIRED 1473479811  
KEYEXPIRED 1473479811

I don't know how to officially report this error. Could you help me to report it?

4
  • Go to "System Settings" → "Software & Updates" and select a different repository server in the "Download from" drop-down menu. Does this solve the issue?
    – Byte Commander
    Sep 11 '16 at 12:33
  • I'm really sorry about asking what i asked. I have seen that I have installed MEGASync. I will remove it and i will see if the error persists. EDIT: After removing the package the error persists, i will do what you said and i will tell you if it worked.
    – Xface
    Sep 11 '16 at 12:37
  • Switching from spanish servers to principal servers doesn't seem to solve the problem. I will restart the system and try to upgrade it.
    – Xface
    Sep 11 '16 at 12:45
  • I still get the same error.
    – Xface
    Sep 11 '16 at 12:51
7

You added a repository from "insynchq" that uses a recently expired key:

pub  2048R/ACCAF35C 2012-09-10            

uid Insynchq Inc <services@insynchq.com>
sig  sig3  ACCAF35C 2012-09-10 __________ 2016-09-10 [selfsig]

sub  2048R/02DFE7E7 2012-09-10            
sig sbind  ACCAF35C 2012-09-10 __________ 2016-09-10 []

It is not an official repository you're having trouble with, but a private one. Likely the company just did not extend the validity period in time. The only thing you can do is to ignore the message for now and tell the company to extend or exchange their signing key. If you do not require the repository any more, simply remove it.

Update: The company extended the validity period, so a simple

sudo apt-key adv --keyserver pool.sks-keyservers.net --recv-keys 0x06BBDC2602DFE7E7

will update the key and re-enable the repository.

2
  • 1
    Sorry. I feel idiot. I didn't see it. I have removed it and all works fine.
    – Xface
    Sep 11 '16 at 13:11
  • Don't worry, all that OpenPGP signing stuff is not easy to understand in the beginning. If the answer solved your question, consider selecting the checkmark on the left (also have a look at the FAQ).
    – Jens Erat
    Sep 11 '16 at 13:14
4
$ sudo apt-key remove ACCAF35C
$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys ACCAF35C
$ sudo apt-get update

Should do the trick.

0

If you think that you have an error to report, then you can go to: https://launchpad.net/ubuntu.

2
  • Thank you! But the error report must be related to a package, and i don't know exactly to which package it is related... Yes, it is GPG related but also affects to the official repositories...
    – Xface
    Sep 11 '16 at 12:58
  • 1
    I finanally reported a GPG error. Let's see what happens...
    – Xface
    Sep 11 '16 at 13:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.