26

I am running Gnome-shell 3.2 in Ubuntu 11.10. Is there a way to hide the firefox title bar and make it like Chrome's ? I would need the min/max buttons in tab-bar. There was a tutorial in webupd8, but that was with compiz.

1

7 Answers 7

16

Notice: HTitle is now discontinued, you can find an archive on Wayback Machine for historical reference.

You could use HTitle Firefox extension to hide title bar. This can be used only with GNOME 3.

2
  • 1
    The addon site currently says it was discontinued. :(
    – LiveWireBT
    Apr 13, 2017 at 9:24
  • @LiveWireBT, I don't think that extension is no longer required since Firefox UI in full screen mode has been changed.
    – Kesara
    Apr 15, 2017 at 22:32
8

I wondered how to do this as well and found that I do not need the title bar in any window if it is full screen in order to safe some pixels, so I did some changes to my metacity-theme-3.xml

/usr/share/themes/Adwaita/metacity-1/metacity-theme-3.xml

<frame_geometry name="max" has_title="false" title_scale="medium" parent="normal" rounded_top_left="false" rounded_top_right="false">
    <distance name="left_width" value="0" />
    <distance name="right_width" value="0" />
    <distance name="left_titlebar_edge" value="0"/>
    <distance name="right_titlebar_edge" value="0"/>
    <distance name="title_vertical_pad" value="0"/> <!-- 
                            This needs to be 1 less then the
                            title_vertical_pad on normal state
                            or you'll have bigger buttons                               -->
    <border name="title_border" left="0" right="0" top="0" bottom="0"/>
    <border name="button_border" left="0" right="0" top="0" bottom="0"/>
    <distance name="bottom_height" value="0" />
</frame_geometry>

With the "Menu bar" unticked, it just looks like Chrome. :)

There is also a Gnome 3 extension for this: Pixel Saver.

PS: I can also recommend the GNOME 3 theme for a consistent look and feel (scroll bars etc).

4
  • But what about the minimize and close button
    – meteors
    Jul 23, 2013 at 5:05
  • I never minimize windows (I just move them to other workspaces) and I close windows using shortcuts such as Ctrl+Q.
    – gncs
    Jul 23, 2013 at 5:28
  • Pixel Saver was exactly what I was looking for in Gnome Shell. I use Super+up/down/left/right to maximize/unmaximize/move to left or right half of the screen. Alt+F4 to quit. No need for minimize/maximize buttons (for me - I understand it doesn't answer OP's question)
    – Jay
    Jul 5, 2016 at 14:09
  • 1
    That Pixel Saver extension was what I was looking for, very good!
    – LiveWireBT
    Apr 13, 2017 at 9:20
3

I found a solution: Install this extension: https://addons.mozilla.org/en/firefox/addon/hide-caption-titlebar-plus-sma/

  • It'll show that is not compatible with our version, still click Add to Firefox and install.

All credits to WebUpd8: http://www.webupd8.org/2011/03/firefox-4-get-tabs-in-title-bar-like.html

My Desktop

1
  • 1
    This addon is now listed as compatible for Linux. You can also easily disable the orange menu button and the windows like close buttons if you prefer. Apr 6, 2016 at 18:28
3

As of September 2019, this functionality is built into Firefox:

  1. Right click empty space on the tab bar
  2. Select "Customize..."
  3. At the bottom of the window there is a "Title Bar" checkbox. Uncheck it to hide the title bar.

screenshot showing the Customize Firefox tab

2

As the global menu extension in gnome-shell doesn't work with firefox, you have to make do with the firefox extensions.

There is an extension called "Mozilla Labs: Prospector - LessChrome HD 7" which shows the navigation bar only on mouse-over. It works quite well (works also very well with unity).

You can get it here: https://addons.mozilla.org/en-US/firefox/addon/prospector-lessChrome-HD/?src=userprofile

Additionally, in View -> Toolbars, unmark "Menu Bar" and mark "Tabs on top"

Your Firefox window should now look like this:

enter image description here

2
  • Thanks for replying, but it still doesn't answer my question to hide the title-bar. I have Hide Caption Title Bar extension installed, but doesnt seem to work in Ubuntu 11.10.
    – Shrijit
    Nov 28, 2011 at 6:37
  • I am also facing this problem..Does anybody has any suggestions for fixing this? Jan 27, 2012 at 7:26
1

There is a good workaround here. It provides a keyboard shortcut for a fullscreen mode in which the Firefox bars are preserved.

Steps:

  1. Open 'System Settings' (under the user menu top-right on the screen)
  2. Select 'Keyboard'
  3. Click on the 'shortcuts' tab
  4. Select 'Windows' group of shortcuts
  5. Click twice on 'Toggle fullscreen mode'
  6. Type a shortcut (I use Shift+F11)

It's not perfect, but it does 90% of the job.

1

Settings -> Window Manager Tweaks -> Accessibility -> Check "Hide title of windows when maximized"

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.