0

I am new to Linux and just done installed Ubuntu 16.04. I have the local USB printer Brother DCP-7065 DCN and it worked fine in the Ubuntu. However, the Simple Scanner apps does not see the scanner. Steps I took so far.

Downloaded 64 bit scanner drivers brscan4-0.4.2-1.amd64.deb, brscan-skey-0.2.4-1.amd64.deb and brother-udev-rule-type1-1.0.0-1.all.deb. I installed all of them.

sudo dpkg  -i  --force-all brscan4-0.4.2-1.amd64.deb
sudo dpkg  -i  --force-all brscan-skey-0.2.4-1.amd64.deb
sudo dpkg -i brother-udev-rule-type1-1.0.0-1.all.deb  

No errors.

I ran dpkg -l | grep Brother:

ii  brscan-skey                            0.2.4-1                                                     amd64        Brother Linux scanner S-KEY tool
ii  brscan4                                    0.4.2-1                                                     amd64        Brother Scanner Driver
ii  printer-driver-brlaser                     3-5~ubuntu1                                                 amd64        printer driver for (some) Brother laser printers
ii  printer-driver-ptouch                      1.4-1                                                       amd64        printer driver Brother P-touch label printers

I check the config.dll file and see brother4 listed in there.

I ran sane-find-scanner and it said

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

"Unable to connect scanner" message came up when I used Simple scanner .

What I have missed? Thank you.

0

I had this printer before, I only used the debs on the brother's page:

http://support.brother.com/g/b/downloadlist.aspx?c=us&lang=es&prod=dcp7065dn_all&os=128&flang=English

Look for Scanner Drivers you need 32 or 64bit.

Hope it can help you.

0

I tried this solution from this post and it worked. The only thing I changed was set ip to 0.0.0.0 although this is local USB printer.

brsaneconfig4 -a name=SCANNER model=DCP-7065DCN ip=0.0.0.0

Getting my brother MFC-J825DW working as a network scanner

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.