3

I installed some packages a while ago and for some reason, they would only install with a special set of parameters that I used as recommended on a website (can't remember which one).

Now, although harmless, I am stuck with these warnings every time I run apt-get:

dpkg: warning: ignoring option --foreign-architecture=i386: this architecture cannot be foreign

Any idea where is this lying around? How can I clean this up?

| improve this question | | | | |
2

I can confirm. Removing the line foreign-architecture i386

in the file /etc/dpkg/dpkg.cfg.d/multiarch

Removes the warning message: Unknown configuration key foreign-architecture' found in yourdpkg' configuration files. This warning will become a hard error at a later date, so please remove the offending configuration options and replace them with `dpkg --add-architecture' invocations at the command line.

when performing the command: sudo apt-get update

| improve this answer | | | | |
4

It's part of the new multiarch system that lets you install foreign-arch packages on your system.

Have a look at the file(s) in /etc/dpkg/dpkg.cfg.d/, you should see it in there.

I think it's safe to remove if you don't want to use multiarch though I don't know why it should be warning in the first place. Is your physical arch i386 as well or something?

| improve this answer | | | | |
1

just go to the required destination and delete the 'foreign-architecture i386' line.It works.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.