3

I'd rather know how to download the codecs (mp3 flac etc etc) for Audex (ripper), is there a way to get them using the terminal? I have tried with the links available on ubuntu site but nothing happened.

Moreover on Ubuntu they say that there is also the option to access the entries of FreeDB database but all I get is the CDDB database that often does not recognise my cds. How do I add this FreeDB database option? My version of Ubuntu is 16.04

5

The questions really demands two answers:

1. Install the codecs:

The Terminal command to install a fully featured audex including codecs is as follows:

sudo apt-get install audex eyed3 faac flac lame twolame vorbis-tools

Be aware that a very large number of KDE libraries will also be dragged in as dependencies of audex, if these dependencies seem excessive to you consider installing an alternative CD ripper such as asunder which carries no KDE cruft...

2. Change the CDDB database:

This functionality is broken on Xenial Xerus (the packager has possibly missed the dependency on kde-config-cddb) and to fix this you will have to build the package from scratch but as a bonus you get a newer version!

First activate your Sources:

Dash > Software & Updates > Ubuntu Software > Source Code

Place a tick in the 'Source Code' box and then allow the Repositories to reload. Then copy the entire following code box into a Terminal window, it is a single command:

sudo apt-get build-dep audex && \
sudo apt-get install kdemultimedia-dev libcddb2-dev kde-config-cddb checkinstall && \
mkdir -pv ~/audex_build && cd ~/audex_build && \
wget https://github.com/KDE/audex/archive/v0.79.tar.gz && \
tar xvf v0.79.tar.gz && cd audex-0.79 && \
mkdir build && cd build && \
cmake -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr/local .. && make -j 4 && \
sudo checkinstall -D --install=yes --fstrans=no --pakdir "$HOME/audex_build" \
   --pkgname audex --backup=no --deldoc=yes --deldesc=yes --delspec=yes \
   --default --pkgversion "0.79"

Log out and then log back in and you should now see the following:

CDDB Settings for Audex

Note that now you also have an extra tab called 'Device settings' to tweak your CDROM settings. And all the best with ripping your audio cds :)

  • Hi Andrew.46 I have finally been able to install the codecs thanks to your tip. But, since I am a bit dumb, I haven't been able to find a solution with the freedb server. I have opened the audex programme but when I open the "configure audex" there is no "cddb settings" and more importantly no alternative option to CDDB. In the remote server section there's the possibility to add an address "send file to server". Could it be that I have to add a freedb server address there? – Ramalama Belle Sep 10 '16 at 12:01
  • @RamalamaBelle I have added a screenshot showing the required dialogue box but this does not seem readily available on Xenial Xerus. I will dig a little deeper... – andrew.46 Sep 10 '16 at 12:28
  • 1
    @RamalamaBelle Indeed this is the issue. I have created a bug report, perhaps you could also subscribe yourself to this? bugs.launchpad.net/ubuntu/+source/audex/+bug/1622264 – andrew.46 Sep 10 '16 at 23:20
  • 1
    @RamalamaBelle Solved the issue with CDDB, please test it out and let me know if you have any further issues :) – andrew.46 Sep 11 '16 at 6:16
  • 1
    yes yes yes!!it worked!! you really made my day!! :-D Thank you ^^ – Ramalama Belle Sep 11 '16 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.