0

So I recently just installed Ubuntu 16.04 LTS Gnome flavor on my new 128GB SanDisk USB drive. Under my Bios boot mode settings, with UEFI selected, only my ubuntu live usb can be seen whenever I get to the boot manager (F12). But in Legacy boot mode under my Bios settings, I am able to boot into either my live usb, windows or the intended ubuntu 16.04 LTS flash drive.

I am happy the USB drive now works but being still fairly new to this booting method I'm worried as to whether there are any risks or disadvantages using Legacy boot considering I have Windows 10 installed on my internal SSD.

So is it safe? Is there a way to keep my boot mode in UEFI and boot my Ubuntu 16.04 LTS USB without having to tamper with my internal storage?

  • Your Windows is installed in legacy-mode. No reason to worry about. I have three operating installed on two drives, everything in legacy-mode, works flawless. Your USB-flash-drive is shown under both boot-modes because it is bootable in both modes. UEFI is new and bring some advantages which are not really needed in small home computer. Legacy-mode is safe, it has been the standard for many, many years. – mook765 Sep 10 '16 at 7:11
  • @mook765 I just realized I can't boot from my windows from Legacy mode. It just automatically boots from the ubuntu usb flash drive instead. This is the exact opposite of my problem using UEFI (can't boot Ubuntu but it automatically boots windows). I'm lost at what to do. – D-Charlie Sep 10 '16 at 15:55
  • So what happens when you boot to your 128GB SanDisk USB drive. Do you get the Grub-menu then where you can choose Ubuntu or Windows ? – mook765 Sep 10 '16 at 17:34
  • @mook765 no unfortunately, it gives me the boot manager and there is see all my HDDs and My Ubuntu Flash drive listed as a HDD. I select it and it goes straight to ubuntu and shows me the login screen for my ubuntu user account. But I have managed to make some progress. My laptop is an Acer Aspire E 15 so it has an option for "Select an UEFI file as trusted for executing" under the Security tab in the Bios. Selecting it i navigate to HDD1 > ubuntu > grubx64.efi . Mind you I have no idea why this is here since this computer is fairly new and I have not installed ubuntu to any of ... – D-Charlie Sep 10 '16 at 18:59
  • @mook765 ... my internal drives, only to this 128GB usb stick. I select grubx64.efi set its description as 'grub boot' and i allow it as a trusted. I save and lo and behold on restart, after hiting F12 the boot manager now displays both my windows boot and grub boot. I select grub boot and it takes me to the GNU GRUB Version 2.02~beta2-36ubuntu3.2 terminal. From which i followed this tutorial on booting from grub terminal. Thankfully it worked and i faced my log in screen again, but now there is another problem as... – D-Charlie Sep 10 '16 at 19:06
0

This is going to be a bit longer, so I am unable to post it as a comment.

You have three drives attached to your system.The first drive sda has two partitions, sda1 is a Microsoft reserved partition, maybe a leftover from a former Windows-installation on the drive. sda2 is a NTFS-partition, data-storage. The drive has a GPT-partition-table.

On your second drive sdb your recent Windows is installed in UEFI-mode, ESP-partition sdb1 is on this drive. GPT-partition-table.

On your third drive sdcyou just installed Ubuntu, but in legacy-mode, this is the point creating your headache. You should have installed in UEFI-mode. The drive has MBR-partition-table.

You should convert this drive from MBR to GPT, you can use Gparted to do that. Then install Ubuntu again, but install in UEFI-mode. You have to boot the installer in UEFI-mode to do that, how you boot is how it installs. Grub will be installed on the ESP-partition off the internal drive. By default Grub will be installed on the ESP of sda. This fact leads to the next issue.

The ESP-partition should be on the first drive sda, but just right now it is on the second drive sdb. That may lead to boot-problems. I don't know if it is possible to change the drives in your laptop, that would solve this issue. If the second drive is an external drive too, then you have to leave it as it is.

Before doing all that you may try the suggested repair by running Boot-repair again (click recommended repair-button) and see if it works properly. I have my doubts...

I found this and that leads me to another idea. You want to install in UEFI-mode, but you don't want your Windows-drive to be affected in any way. You may try this:

Detach the Windows-drive from the Laptop. Install Ubuntu on the external drive in UEFI-mode. Create ESP-partition on this drive during install (ca.500MB FAT, boot-flag). After install finished reattach the Windows-drive. Boot to external drive to start Ubuntu, run sudo update-grub, so the OS-prober can find Windows and creates Grub-menu-entry. Set boot-order in UEFI-BIOS to external drive. In the case the external drive is not attached you would have to change boot-order to Windows-drive.

No warranty, I can't test that due to missing equipment. But here you can see that I am not the first with this idea...

  • Thank you so much for your time and effort mook765. It finally worked. I loaded up the live usb in UEFI mode repartition the 128GB flash drive as GPT and then proceeded to reinstall Ubuntu on it. Rebooted, at first it didn't show up but then i went to my BIOS and selected option "Select an UEFI file as trusted for executing" under the Security tab in the Bios. Selecting it i navigate to HDD1 > ubuntu > grubx64.efi. After adding the description as grub and saving i rebooted and hit F12 for boot manager. There it was grub, I select it and the grub selection menu comes up. THANKS LOTS! :D – D-Charlie Sep 11 '16 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.