5

I literally just installed Ubuntu onto a VM for the first time today. I created an RSA key using {ssh-keygen -t rsa} and can verify the files exist by way of {ls -l ~/.ssh}. When I go to my home folder the id_rsa.pub and id_rsa files are not there.... there is no ssh folder. In a file under computer/etc, there is an ssh folder, but it contains two files called moduli and ssh_config. What am I doing wrong? I'm supposed to send the .pub file to our server administrator for a class and don't know where it is. Please help this newbie.

  • 2
    If you're looking for hidden files ("dotfiles") in the file browser, you will need to select 'Show hidden files' from the menu (or by using the shortcut Ctrl+H) – steeldriver Sep 10 '16 at 3:34
  • Oh my gosh, it took me a minute of hovering around and clicking on different settings and properties, but I found the 'Show hidden files,' and there are my files. I know this is way silly for probably anybody on here, but I have been racking my brain and PC for a couple of hours on this. Eternal thanks... – Michelle_M Sep 10 '16 at 3:45
  • Didn't it prompt for an output folder? Also, which version you are using? – Nandakumar Edamana Sep 10 '16 at 3:56
  • I mentioned it was supposed to be in my home folder, and so it was. It was just a hidden file and I didn't know to look for, nor where to find how to select that preference. @steeldriver got me straightened out, but thanks for the help. – Michelle_M Sep 10 '16 at 4:07
1

You got a message like this:

Your identification has been saved in /home/b/.ssh/id_rsa. Your public key has been saved in /home/b/.ssh/id_rsa.pub.

Open your home folder and press Ctrl + H and you'll see folder .ssh

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.