8

I'm quite new with Ubuntu, I ve just installed Ubuntu 16.04.

I was "playing" with it and I discovered a strange thing.

I have a ssd with 3 partition, 1 in ext4 with Ubuntu, 1 in NTFS with windows10 and 1 with no operating system in NTFS.

I ve noticed that when I copy a file from NTFS to ext4 it goes very quickly, for example 2 GB are copied in 10-20 sec. But when I try to copy something from ext4 to NTFS everything goes very slowly, like 100-200 kbps.

Is there a solution to fix it? Why is it happening? I'm really curious about that!

Thanks for your attention :)

8
  • 1
    Blame NTFS, I'd say...
    – Byte Commander
    Sep 9, 2016 at 15:31
  • Do you have the ntfs-3g package? Because you can mount it, I'm expecting you do, but there might be a special case where it was mounted a different way. Can you check how it was mounted? Sep 9, 2016 at 15:32
  • @Zzzach... thanks for your reply! I told Ubuntu to automatically mount it using this command: UUID=<uuid> <pathtomount> <file system> uid=<userid>,gid=<groupid>,umask=0022,sync,auto,rw 0 0
    – Jack
    Sep 9, 2016 at 15:46
  • 3
    @Zzzach... i have founded a solution, i've changed the sync to async in this command that i used to tell ubuntu to auto-mount the disk: UUID=<uuid> <pathtomount> <file system> uid=<userid>,gid=<groupid>,umask=0022,sync,auto,rw 0 0. But is thanks to you that pointed me in the right direction to find the problem, thanks =)
    – Jack
    Sep 9, 2016 at 16:05
  • 1
    @Jack Glad I could help out, but you solved the problem on your own! Be sure to answer your own question (below) and mark it as the correct answer so that others with the same issue can easily find the answer. Sep 9, 2016 at 19:12

2 Answers 2

6

I have founded a solution: I’ve changed the sync to async in this /etc/fstab line that I used to tell Ubuntu to auto-mount the disk:

UUID=<uuid> <pathtomount> <file system> uid=<userid>,gid=<groupid>,umask=0022,sync,auto,rw 0 0.

(Source for auto-mounting the disk when the system starts)

4

I have had this problem in the past.

First, make sure ntfs-3g is installed. In Ubuntu and other distros, I have been able to mount drives without it, but always had corrupted data and strange permission problems.

The next thing to do is to mount the drive with the big_writes option as follows, which will help with getting much better write speeds on NTFS drives.

sudo mount -o big_writes /dev/sdX1 /mnt/media
1
  • 1
    This big_writes option seems to somewhat speed up the write speed, now if I could only make KDE use this option without me remounting the partition manually every time...
    – soger
    Jun 13, 2018 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.