2

I am attempting to open a .jar file with java 8 but it gives me an error message asking for admin privileges:

Please start the Authenticator with admin privileges

I am completely new to this type of issue, so my first reaction was to run sudo java -jar /home/sethlord/Downloads/Authenticator/Authenticator.jar in a terminal, but it gave me the same error message. Any fix?

3

The classical method would be ...

sudo -i
java -jar /home/sethlord/Downloads/Authenticator/Authenticator.jar

If you really really need "root"

sudo -su
java -jar /home/sethlord/Downloads/Authenticator/Authenticator.jar

But try to avoid that since it logs notices to user "root" and not the "sudo" account.

  • I tried both of these, it simply gave the the same error message – Lokii Sep 9 '16 at 14:50
  • Java is cross-platform. So it shouldn't matter. – Android Dev Sep 9 '16 at 14:53
  • where did you download it from @lokii google search did not get me a result :P – Rinzwind Sep 9 '16 at 14:58
  • mcleaks.net/authenticator maybe my mistake is really obvious, but like i said, im a noob – Lokii Sep 9 '16 at 15:18
  • "Open the "MCLeaks Authenticator" folder and run following file: - Windows users: MCLeaksAuthenticator.exe - OSX users: Run Authenticator.command" You picked the windows or the Mac OS version? – Rinzwind Sep 9 '16 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.