0

I'm running Ubuntu 16.04 LTS on a Gigabyte Aero with an Elantech touchpad. The output of xinput looks like:

david@Aero:~$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Bluetooth Mouse M557                      id=12   [slave  pointer  (2)]
⎜   ↳ E-Signal Keyboard                         id=14   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=17   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Power Button                              id=10   [slave  keyboard (3)]
    ↳ Sleep Button                              id=11   [slave  keyboard (3)]
    ↳ E-Signal Keyboard                         id=13   [slave  keyboard (3)]
    ↳ Chicony USB 2.0 Camera                    id=15   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=16   [slave  keyboard (3)]

Edit: Details from xinput on the touchpad:

david@Aero:~$ xinput list-props 17
Device 'ETPS/2 Elantech Touchpad':
    Device Enabled (168):   1
    Coordinate Transformation Matrix (170): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (296): 1
    Device Accel Constant Deceleration (297):   2.500000
    Device Accel Adaptive Deceleration (298):   1.000000
    Device Accel Velocity Scaling (299):    12.500000
    Synaptics Edges (326):  127, 3061, 112, 1973
    Synaptics Finger (327): 1, 1, 0
    Synaptics Tap Time (328):   180
    Synaptics Tap Move (329):   167
    Synaptics Tap Durations (330):  180, 100, 100
    Synaptics ClickPad (331):   1
    Synaptics Middle Button Timeout (332):  0
    Synaptics Two-Finger Pressure (333):    282
    Synaptics Two-Finger Width (334):   7
    Synaptics Scrolling Distance (335): 76, 76
    Synaptics Edge Scrolling (336): 0, 0, 0
    Synaptics Two-Finger Scrolling (337):   1, 1
    Synaptics Move Speed (338): 1.000000, 1.750000, 0.052507, 0.000000
    Synaptics Off (339):    1
    Synaptics Locked Drags (340):   0
    Synaptics Locked Drags Timeout (341):   5000
    Synaptics Tap Action (342): 2, 3, 0, 0, 1, 3, 0
    Synaptics Click Action (343):   1, 3, 0
    Synaptics Circular Scrolling (344): 0
    Synaptics Circular Scrolling Distance (345):    0.100000
    Synaptics Circular Scrolling Trigger (346): 0
    Synaptics Circular Pad (347):   0
    Synaptics Palm Detection (348): 0
    Synaptics Palm Dimensions (349):    10, 200
    Synaptics Coasting Speed (350): 20.000000, 50.000000
    Synaptics Pressure Motion (351):    30, 160
    Synaptics Pressure Motion Factor (352): 1.000000, 1.000000
    Synaptics Resolution Detect (353):  1
    Synaptics Grab Event Device (354):  0
    Synaptics Gestures (355):   1
    Synaptics Capabilities (356):   1, 0, 0, 1, 1, 1, 1
    Synaptics Pad Resolution (357): 31, 31
    Synaptics Area (358):   0, 0, 0, 0
    Synaptics Soft Button Areas (359):  1594, 0, 1709, 0, 0, 0, 0, 0
    Synaptics Noise Cancellation (360): 19, 19
    Device Product ID (285):    2, 14
    Device Node (286):  "/dev/input/event8"

Gnome (via gnome-settings-daemon?) starts up an instance of syndaemon on login:

david@Aero:~$ ps aux | grep syndaemon | grep -v grep
david     4275  0.0  0.0  22372  1164 ?        S    08:35   0:00 syndaemon -i 1.0 -t -K -R

However the '-t' option is problematic on my machine. If I killall syndaemon and re-run it with my preferred options (-i 1.5 -K -d) it works great. Unfortunately, setting my startup app's command to killall syndaemon && syndaemon ... doesn't actually kill Gnome's instance, likely because the startup applications run before Gnome runs its instance.

The generally-accepted way to disable Gnome's instance of syndaemon launched on login is to "Uncheck the 'Disable while typing' option in Mouse & Trackpad settings" - but for me that option does not appear. I'm guessing this is because I don't have a Synaptics touchpad?

Screenshot of Mouse and Touchpad Settings

(Another laptop I have, a Samsung 9 series with an Elantech touchpad running 14.04LTS, does show the checkbox.)

So I need one of the following:

  • A way to disable Gnome's on-login launch of syndaemon without unchecking that box, or
  • A way to make the box appear so I can uncheck it?

Thanks!

2
  • lease edit your question and add output of xinput list-props 16 terminal command. – Pilot6 Sep 9 '16 at 14:50
  • Whoops, looks like I had a config change somewhere in there and added the wrong ID. Fixed it now. – mtbkrdave Sep 11 '16 at 0:10
0

I found a usable workaround, but remain interested in learning if there is a "proper" way to do this....

I renamed /usr/bin/syndaemon to /usr/bin/syndaemon.priv and invoked the latter in my startup application command line. Gnome can't find the original syndaemon executable and its invocation fails.

0

If you install touchpad-indicator, it has functions to disable the touchpad whilst typing, and many settings that you can configure.

If you don't see touchpad-indicator in your Synaptic, you can go to https://www.atareao.es/apps/touchpad-indicator-para-ubuntu/ for more information.

You can also add his repository by entering these commands in terminal:

sudo add-apt-repository ppa:atareao/atareao

sudo apt-get update

sudo apt-get install touchpad-indicator

Cheers, Al

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.