1

Okay, I´ve seen the other problems which people have had when doing a fresh install and then the system not booting...

This is different. I´ve been using it for over a year with no problems.

This morning when I woke up, I forgot that the laptop had not been charged last night. There was very little battery when I turned it off. This morning I turned it on while unplugged. There was just enough battery to load in the OS and for me to see that there wasn´t enough battery at all.

After putting my password in the log in menu, the system began finishing up boot. Then the battery ran fully out and it powered down the system.

When I plugged the laptop in and turned it on, it did the following...

  1. Show Samsung logo
  2. Show boot menu (not GRUB, but hard boot menu)

In the system boot menu, there is NO Operating system listed at all. My Ubuntu is not there.

No matter what I try, what button I press during step 1, there´s no way to get it to another menu. I´ve tried all the F keys plus the Delete key

My laptop is a Samsung series 5 Ultra 530U with a changed out SSD hard drive.

So even if I wanted to reinstall ubuntu (have the USB stick right here) I´d have to get to BIOS first in order to set up UEFI booting. Since I have no idea how to get to BIOS, I am pretty lost at this point.

What is my best course of action? I know that my data is safe pretty much since it´s not encrypted on the HD, so I can recover my stuff if I do this properly. I´m hoping someone sees this soon.

  • While you've described trying a number of keys to get into your bios, it's important to use the right key. Sometimes it take more than one try to hit the key at the right time, so that would been that you would be trying countless keys and not sure if it's the right key that had to be hit during the right moment. The resolution is to check your computer's manual or manufactorer support channel to get the right key and use that one a few times for the right timing. You might also edit and add your make/model # to your question. – L. D. James Sep 9 '16 at 12:05
  • If you tell us your Samsung Laptop model we can tell you the function key(s). – WinEunuuchs2Unix Sep 9 '16 at 12:13
  • I went and asked an experienced friend and it seems that this is probably my laptop´s keyboard. I´m disconnecting it now to see if this is true. It seems that it´s always going to the boot menu because of quite possibly a stuck key or key command. The weird part is that there is no device in the boot menu. Since this I have tried booting with different hard drive, etc. It doesn´t matter what I do, it always goes to the boot menu. – webDOMinator Sep 12 '16 at 16:45
0

You might want to try putting my rEFInd boot manager on a USB flash drive or CD-R. With any luck, your computer will show that as a boot option when you start up, and you'll be able to get into Ubuntu. You can then use efibootmgr to examine the boot list and, if necessary, reset the ubuntu item to the top or create a new entry. (There are lots of efibootmgr tutorials on the Web, but most are limited. Try this one or this other one to get started.)

Another option would be to use Boot Repair to re-install GRUB; however, a complete GRUB re-installation is overkill, and poses a small risk of messing something up that worked before. Doing this may be easier than learning to use efibootmgr, though. Note that you'll need to boot a Linux emergency disk (like the Ubuntu installation medium in "try before installing" mode) to run Boot Repair. Be sure to boot in EFI mode, unless of course your installation was in BIOS mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.