9

I suddenly got my desktop machine to fail booting with no obvious reason. I haven't made any significant changes/updates since the last shutdown. Here is what happens:

Normal boot sequence throws me off to tty1. After successful login:

/usr/lib/ubuntu-release-upgrader/release-upgrader-motd: 31: /usr/lib/ubuntu-release-upgrader/release-upgrader-motd: cannot create /usr/lib/ubuntu-release-upgrader/release-upgrader-available: Read-only file system
/usr/lib/update-notifier/update-motd-fsck-at-reboot: 33: cannot create /usr/lib/update-notifier/update-motd-fsck-at-reboot: Read-only file system

Welcome to Ubuntu 16.04.1 LTS! (<kernel_version>)

0 packages can be updated

0 updates are security updates

*** /dev/sda2 should be checked for errors ***


user@user:^$ _

Note: Switching to tty7 doesn't work. The screen blanks a little and then that's it

Going through recovery mode and running fsck gives:

recovery_mode_fsck

Issuing the command shown (systemctl ...) through a root shell gives:

command_issued

Any help is appreciated

2 Answers 2

13

For me, this problem appeared after I installed a backup with wrong/old fstab UUIDs. I had to view the right UUIDs with sudo blkid and update my /etc/fstab file accordingly.

4
  • I have the correct UUIDs in fstab, Still my system gives this error (It boots fine though) Jul 21, 2020 at 6:23
  • @snickers2k worked fine for me, thank you a lot
    – Cerber
    Nov 6, 2020 at 16:50
  • Thanks! This fixed my glitchy Raspberry Pi that was displaying the same error message on boot
    – Parker
    Mar 8 at 17:25
  • Thank you so much!!
    – Davide
    May 30 at 12:25
9

Lets first check your file system for errors.

For Ubuntu 17.10 or older...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

For Ubuntu 18.04 or newer... (or if the above steps don't work for you)...

  • boot to a Ubuntu Live DVD/USB in “Try Ubuntu” mode
  • open a terminal window by pressing Ctrl+Alt+T
  • type sudo fdisk -l
  • identify the /dev/sdXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/sda2, replacing sdXX with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot
3
  • You can't force a check while any partition is mounted. I unmounted / then forced a check. Turns out there were a couple of orphaned nodes need to be fixed and then boot resumed flawlessly. Thank you. On a side note: do you think that preventing fsck to do periodic checks might have caused the issue ?
    – egy
    Sep 9, 2016 at 22:14
  • 2
    You don't want to disable fsck checks. Cheers, Al
    – heynnema
    Sep 9, 2016 at 23:36
  • @egy It's possible. It's happened to me before. May 24, 2017 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.